Mazda MX-6 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
My 93's KLDE appears to be dead. It seized up after spinning a few bearings. The crank is in rough shape. I've been online and making allot of calls trying to figure out options. Man this has been tough. Can't find a longblock or crank kit. It appears as if they aren't being made anymore. Very few KL motors on Ebay. What i did find was a few KFs. But honestly I don't want to take the risk w that and I don't care for KFs. So I'm thinking maybe going w a KLG4. But not hot on the idea of making tons of mods to accommodate it. Also, I'll be bringing the siezed Klde engine in peices to a machine shop soon to figure out what can be reused w my engine. Hoping for the best but planning for the worst. Any thoughts on alternatives?
 

·
Registered
Joined
·
317 Posts
There must be KLDE engines around. Many of them in models 626 and Millenia. Importers, JDM. I got a replacement KLDE engine and auto transmission off a Millenia. That was 4 years ago, and runs like new and uses no oil.
 

·
Registered
Joined
·
2,337 Posts
Should be able to swap some of the external items over and run a g4 pretty easy... don't think there's any more work than swapping a straight neck ze in. We have installed one, but very little run time before swapping again, temporary install/ fitment test while actual engine was being built. But it did run and drive for a couple weekends, then removed shortly after. I have run the g4 manifold on my car for years, slight movement of some vacuum lines and solenoids, but wouldn't go back.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Happily, I avoided an internet purchase. I found a used KLDE, out of a 93 626. It was at a salvage yard. Only had to drive 2 hours. I'm rebuilding it now. Any tips on who makes a good oil pump. Looking at a SKP from Rauto.
 

·
Registered
Joined
·
3 Posts
My 93's KLDE appears to be dead. It seized up after spinning a few bearings.
Can you elaborate on what caused the failure of your motor? High miles? Abused from previous owner? Oil pump failure? I'm always curious. My 93 LS is bone stock with 134K miles on her, and sometimes I'm afraid to take her out for a cruise for fear of something BAD happening. Yeah, I'm a nervous type, LOL. But I brought this car home from the stealership brand new in 93 and if it dies before me, ....well that just wouldn't be right. Right? Haha.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
First rebuild was due to a radiator cracking its tank. This happened while driving, full speed, down an interstate. The engine overheated in the blink of an eye. It blew a head gasket before I could get off the road. The motor had 165kish on it. I decided to do a total rebuild because of its high mileage. When I tore the engine down I found allot of very worn bearings. It was indeed a good time for overhaul.

Then the car was doing fine, for many years, after the rebuild until one very foggy morning, I accidentally drove over an object in the shoulder. It tore a hole in the oil pan. Not knowing this at the time, I drove on it. In less than a few minutes the motor siezed due to oil loss. I should have stopped and got a tow. This was my fault. But it did teach me that these engines, KLDEs, are somewhat more delicate than others I've owned. Still I'm attached to this car and putting it back on the road very soon. I hope this helps.
 
1 - 8 of 8 Posts
Top