Mazda MX-6 Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
What does this sound like? My lights dim when I come to a stop (interior as well as headlights.) They brighten back up immediately at the stop. Sometimes in stop and go traffic the lights flicker. This has been happening for awhile. The alternator is a few years old and is a rebuilt Bosch. The battery is from about a week before the alternator. I haven't noticed any change in the radio (volume or tape speed) when this happens and this happens on short trips or after an hour of driving. Anything I should check or do?
 

· Registered
Joined
·
269 Posts
check the voltage on the battery when the car is off, then check it again when the car is running and see if there is a difference in readings. your battery might not be holding a charge.

Ryan
 

· Registered
Joined
·
663 Posts
Yeah, and I found out last week when MY alternator went out that the voltage regulator is internal, IE: a part of the alternator. Just replace the whole thing.
 

· Registered
Joined
·
45 Posts
Discussion Starter · #7 ·
no - just the factory system with a speaker not working. The lights are bright at a stop - just at the end of braking they dim. They also flicker sometimes starting to go in stop and go traffic. This happens more often in cold weather - the colder it is the worse the problem is.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top