Mazda MX-6 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter · #1 ·
Just sprayed down the engine at the car wash (stupid). Now the engine bogs down whenever I push the gas over half. What should I look for? shorted spark plugs?
 

·
Registered
Joined
·
1,429 Posts
what do u mean by bogs down? was it a pressure washer? ive done it before and had no problem if i let it run for a lil bit
 

·
Premium Member
Joined
·
7,196 Posts
I did that once before, only with a regular hose. Did you cover up all the elctrical parts? I made sure to cover the distibutor and battery, but water got into the spark plug wells somehow. Check to make sure it' dry in there, and if not that may be it.
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #4 ·
it is now shaking while it idles, if i increase the case at all it will not do anything, then it bucks if i keep the gas pedal down for say 10 seconds...hope i didnt short out the computer or a fuel injector..im hoping its the plugs right now, ill check tonight
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #5 ·
ok, well i cleaned off the plugs, replaced them. Ran the engine for a 1/2 hour and it is running fine. thank god.

Now i got this very anyoing sqeak when i push in the clutch or release the clutch pedel. Must be the clutch cylinder/sleeve (found from searching!). Is they anything that can be used to stop the sqeak temporarily?? the noise drives me nuts...ive tried WD-40, that stopped it but then gave me problems with engaging the clutch (was hard to switch gears and clutch pedal would not come back all the way). That problem is not gone. I tried using a little grease at the "plunger"...any ideas?
 

·
Registered
Joined
·
3,092 Posts
wd-40 is a penetrant, not a lubricant.

if the squeak is coming from the tranny itself, it either the slave to the t/o fork, the t/o fork on the pivot ball or the t/o fork on the t/o bearing... could also be the t/o bearing on the input shaft sleeve.


have someone push the clutch while you listen for it.
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #7 ·
The squeak is coming from the inside of the car. After i used wd-40 on the plunger/cylinder inside the car it stopped the squeak for a while.
 
1 - 7 of 7 Posts
Top