Mazda MX-6 Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
okay... heres the scenario. driving home from our local monday and tuesday night hangout... my car just stopped running. it made the same kind of noises a 4 cylinder do with nothing on the MAF... which is kindof an "out of gas" type thing. this made perfect sense, though, because, the next day, when i went to go take a look at my car, the INTAKE WAS GONE!!! apparently my intake was stolen from right under my hood, because it is VERY unlikely that it just fell off. it was secured very tightly. anyway... my point is, the car will not turn over now... even after i put my old airbox back on. im fearing the worst, and that is that all kinds of impurities were sucked into the engine (due to the lack of any filter). would something like this cause it to not start? if so... how do i fix a problem such as this? please... any possible ways to fix this problem are welcome...
 

·
Registered
Joined
·
806 Posts
How far did you drive it, and did you have to have it towed home? Sorry, I would suspect more foul play than just a missing CAI. I am paranoid like that though, I hope its simple and fixable. I know an intake for a V6 would be hard pressed to fall completely off and me never know it was gone.
 

·
Registered
Joined
·
3,167 Posts
How many miles on it? If more than 60,000, when was the timing belt replaced?

Is there a spark? (Pull a plug wire, stick in an old plug and lay it on the valve cover. Crank the engine. Do you see a spark jumping the gap?) If not, remove the distributor cap and crank the engine...make sure the rotor is turning. If it is, you might have a bad igniter/ignition module. If the rotor isn't turning, the timing belt is baffed.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #4
i checked for a spark... and there is none. is this my distributor cap? or is it the whole distributor... and does anyone know what it would cost to get either one replaced?
 

·
Registered
Joined
·
2,064 Posts
I'd go ahead and check for the distributor rotation too. No spark could be either timing belt or igniter. You won't know until you see if the distributor rotor is turning (cam/timing belt).

Tyson
 

·
Registered
Joined
·
1,185 Posts
no spark means the igniter/coil is screwed... its a common problem on the 93 and 94 models... i just payed 450 canadian for the part... rather expensive but the car runs so much nicer now... BTW since you were running with no air filter for a while, after you get the dsitributor fixed and the car running i suggest cleaning out the throttle body... it did wonders for my car.... peas
 

·
Registered
Joined
·
3,092 Posts
NOPE!!!!

igniters dont go bad on the 4 bangers... at least not as much as the V6s.

my friend had the same problem and i tried to fix it for him. he bought the car out of a yard with a blown engine and decided to put a new one in there. the disty was fine because we popped it into a 626 and fired it right up. theres no spark, everthing else is fine. its really wierd.

he takin the car in on monday to hook it up to some diagnostic computers. ill post the problem and solution.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #8
okay... my uncle had a look at it today. apparently i am stupid, because there IS a spark. he said "fuel isnt getting to the engine at all. which may mean its a fuel pump OR a fuel filter problem." now, would either of these just quit while i was driving? i STILL think it has to have something to do with my mysteriously vanishing cold air intake. due to the fact that anytime i take everything off the MAF, it starts, but REFUSES to rev. it just makes sort of a gurgling sound. but now i have my stock airbox back on, and it won't do anything at all. i'm in the dark.
 
I

·
Guest
Joined
·
0 Posts
Fuel huh?

Hey Brian, how did you find out there was spark? You said there was none when we took out the plug and checked. I could've swore there wasn't any. Anyways here's a question. Do MX-6 have a fuel pump reset switch? IT's used whenever a car gets into an accident, it's set off to shut the fuel pump off to keep any gas from coming out in the engine bay froma collision. If somehow this got set off, lets say a short, or something like that, couldn't you reset it and find out. In my car it's on the left side of the trunk, right under the carpet. I dunno, I was just wondering, cause it would be worth a try to just reset it and see what happens.
 

·
Registered
Joined
·
93 Posts
wtf!!!

What the hell is going on, I just posted above, and it comes up as IMA SINNER. Who the hell is that. It's not me, and I don't like men. What the hell is wrtong with this board.

well, anyways, Brian, I'm the one who posted about the fuel pump reset. Administrators, why did my last post have this user name. I don't even know who that is. :mad:
 

·
Registered
Joined
·
3,092 Posts
LMFAO!!!! YOU LIKE MEN!!! j/k... that was pretty funny

no fuel eh? someone said something about foul play... check the lines on you FPR. if that doesnt work, check the fuel after the filter by pulling the hose that connects to filter off (from the non-filter end) and crank the engine. you might wat to get a gas can or milk carton and aim the hose into there. thatll give you some direction...
 
H

·
Guest
Joined
·
0 Posts
engine dying

I'm not sure what the prob. is but i would suspect more of a fuel filter/line problem. I read somewhere that u can drive short distances w/o an air filter.
 

·
Registered
Joined
·
93 Posts
Yeah, I doubt anything serious could've gotten into the MAF, since that screen is in there. There wasn't even anythin up against the screen when we looked.

Brian it wasn't raining that night was it?
 

·
Registered
Joined
·
3,092 Posts
you never had a CEL this whole time?
 

·
Registered
Joined
·
135 Posts
Discussion Starter #15
no rain that night... no CEL at all... havent gotten one in a long time in my car (i know it works though).

possible scenario: cai somehow (dont ask me how, it was on really well) fell off... bumping fuel cutoff switch in the process. i honestly dont know how else it would have happened! lol.

anyway... my parents want me to take it to a mechanic, where i can be lied to about the problem, and charged for parts i don't need. i don't see this happening.
 

·
Registered
Joined
·
3,092 Posts
LOL...thats funny. so who knows where the reset is?
 

·
Registered
Joined
·
135 Posts
Discussion Starter #17
interesting.

i got my cold air intake back tonight (no need to make a new one, aaron, but thanks for the offer!). apparently on... i believe it was sunday night, i left the local "hangout" after putting some oil in the beast. the intake simply fell off when i was leaving, as a friend of mine saw it happen, and picked the intake up off the road. so i was running all over the place on monday with nothing on my MAF. lets see... i went to work, and of course, the traditional "wing night" run out to sharkys in latrobe... all of which totaled about... ummm... 50 miles or so, with nothing on the MAF.

i'll still try the fuel reset, but at this point, i am 100% that this totally has everything to do with my intake departing from the vehicle. when it stopped running, it made the same gurgling noise as when i give it gas any other time with the MAF left un-intaked (note extreme butchering of the english language).

so here is my plan of action tomorrow.

1) unplug battery to reset computer (seems like a good idea... maybe it will "sense" that theres something on the damn MAF once its reset.)

2) hook up the intake and pray

3) attempt to start vehicle. if it doesn't work, expect heavy swearing, a hissy fit (i'm really good at these), and a general "i hate you" attitude for the rest of the day.

if it DOES work, though... expect me to pee my pants in happiness. also... im going to construct a support bracket for the exhaust, to avoid similar future disasters. too bad i suck at building stuff and i will most likely say "f#ck this" and throw the building materials across the driveway 5 minutes into the project.

wish me luck.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #19
my mistake. it was about 3 am and i was pretty tired when i wrote that one.

also. i tried everything. of course, it didn't work. hence, my car is now resting at hamilton mazda, where it will be fixed tomorrow morning.

i threw one hell of a fit today. i also made the problem worse, and hurt myself in the process. sounds pretty common for me.
 
1 - 20 of 21 Posts
Top