Mazda MX-6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
My Mazda MX6 is playing up...

On the way home last night the engine died (Just cut out). Odd....Started again and died again. Then would not start and had to leave for a couple of mins, it would start but then die when the engine was reved!!

Managed to crawl home at MAX 2,000rpm, the car only died twice in 15 miles or so. But only due to the fact that I was crawling the car back.


Now....whats bloody wrong with it....The engine has fuel in the tank, oil and coolant OK. Engine revs OK, no extra noises, but then just cuts, cannot even bump start the car.


My thoughts..

1) Some sensor playing up cutting the electrics to the engine.
2) Fuel Pump.
3) Fuel Filter.
4) Lack of jam.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
I an 99% sure it is the Ignitor module and coil in the Distributer. Common problem on the 93-94 models.

But...

Just taken a look under the bonnet and 3 out of the 6 spark plug holes are full of nice oil!.

Not all in the same cylinder bank, 2 in the front and 1 at the rear bank.

Car idles fine, engine is smooth as a peach and no missfires. No water in the oil etc.

Err....any ideas whats going on there?
 

·
Registered
Joined
·
3,167 Posts
Willf said:
Just taken a look under the bonnet and 3 out of the 6 spark plug holes are full of nice oil!.

Not all in the same cylinder bank, 2 in the front and 1 at the rear bank.

Car idles fine, engine is smooth as a peach and no missfires. No water in the oil etc.

Err....any ideas whats going on there?
Leaking valve cover gaskets. Also a common problem. The oil can damage the plug leads and cause rough idling and misfiring.

If it was mine, I'd replace the disty (or ignitor & coil if you can get just them) and in the same service, replace the valve cover gaskets and the plugs & wires too. Might get expensive but all this stuff has to get done some time or another.
 

·
Registered
Joined
·
61 Posts
okay, with all these "common problems", should i be more cautious when searching for a '93 ls? i would think that most of these problems would have already been repaired by previous owners, or dealers, but i don't know.
 

·
Registered
Joined
·
3,167 Posts
wantmx6 said:
okay, with all these "common problems", should i be more cautious when searching for a '93 ls? i would think that most of these problems would have already been repaired by previous owners, or dealers, but i don't know.
You should be careful when buying any used car. To one degree or another, all cars will have "quirks" that you should be aware of. Unfortunately, the 93 MX6 has a few:

- igniter/distributor; look for it to have been replaced
- rear calipers; look for evidence of replacement/rebuilding and/or inoperative parking brake
- valve cover gaskets; leak oil and bugger up plug leads
- carbon knock; affects 1993 V6s only. Not critical, but look for good maintenance records (i.e. proof of O2 sensor replacements, plug wires etc). Regular decarboning keeps this problem at bay
- friction gear assembly; when bad, rattles like hell. Doesn't hurt motor but sounds like rock-tumber, especially around 2000RPM. Was addressed with component change in 1995
- ATX; not good reliability record in any year. MTX will not take excessive abuse. Slightly notchy 1-2 shift normal. All others should be smooth
- CV joint boots; inspect for cracks or rips

I'm sure there are others. As you've said, you'd think that by now most issues would have been addressed but some owners just let things slide and slide...

Caveat emptor
 
1 - 7 of 7 Posts
Top