Mazda MX-6 Forum banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
I will be replacing worn engine mounts in the near future and am wondering if Energy suspension make any polyurathane mounts for us. I heard to keep a smooth ride just replace the fore and aft mounts with Energys and use new oem mounts on sides and Trans.
Has anyone ever replaced theirs. Do you know how involved it is and if there are any tricks. It seems as though I have a Transmission problem, but I've heard that bad/worn engine mounts can create that illusion. Any help greatly appreciated.

Thanks, Dave
 

·
Registered
Joined
·
405 Posts
when you say u think you have a transmission problem, what exactly do you mean? do you have a ATX? i know on mine when i am stopped in drive the car shakes badly. but if i bump the idle up a little it is fine. i belive on the 90's and up they changed the engine mounts to correct this problem.
 
G

·
Discussion Starter · #3 ·
Engine mounts

Hi yes i have an ATX in a 92 dx, it feels like my transmission lerks into 2 and 3, its just not as smooth as it used to be. then earlier this week I didn't know what it was at first but my car shook badly when accelerating, and like yours vibrated like crazy when stopped in drive. it was really really annoying and chaotic. it stopped a day later as if the mount realigned itself temporarily. now, i know for sure that i have bad engine mounts but do you think i still might have a tranny problem. could bad engine mounts simulate a misunderstanding. Do you know if energy makes mounts for our cars. Any help is great.

Dave
 

·
Registered
Joined
·
1,426 Posts
Do a search on polyurethane reinforced mounts or something like that. I reinforced mine with polyurethane from a tube from the hardware store, just by squirting it into the air spaces moulded into the mount. Worked good.
 
1 - 4 of 4 Posts
Top