Mazda MX-6 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 · (Edited)
so i finally got everythin together
t3/t4 turbo
valent turbo pipes
38mm wastegate
ssqv bov(ebay)
boost controller
255lph fuel pump
280cc injectors
12:1 fmu....
today i put the injectors and the installation went good. i turned on my car the idles good doesnt shake or anythin and when i drive it fine. i have a a/f ratio gauge on my car. when its at idle it doesnt go rich and lean, it stay at lean or lower i would guess because the gauge wont show anythin. and when i gas of course it runs rich and when i drive it and just hold the pedal and drive regular it runs rich and lean like it should. is that normal because the injectors are bigger?
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #3 ·
na its a autozone gauge. i knoe i should get a wideband tho ima try in about a week or so.
but it looks like its going ok tho. i drove it a couple of times and it run rich and lean. but it does seem kinda slow lol.
tomorrow fuel pump. is the wiring hard?
 

·
Registered
Joined
·
941 Posts
na its a autozone gauge. i knoe i should get a wideband tho ima try in about a week or so.
but it looks like its going ok tho. i drove it a couple of times and it run rich and lean. but it does seem kinda slow lol.
tomorrow fuel pump. is the wiring hard?
fuel pump isnt that bad the worst part is getting the gas tank down after that its cake
 

·
Registered
Joined
·
213 Posts
Stock fuel injectors will do, dont get millenias unless you are msns.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #8 · (Edited)
serious!! damn oh well im planning to ms soon but not now
well i got the fuel pump up took me awhile tho, nothing ever bolts up right...
still need to install the fmu tho and
ima start on the pipes on monday everything seems pretty simple im just kinda iffy on the whole oil feed and return lines but ima have valentino (the one that made the pipes from probetalk) to help me out on that.
also ive notice that the car seems slower id the normal because theres not fuel management?
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #9 ·
hey i found this post on connecting the vaccum lines for the turbo

Step 13: Install the vacuum lines

On the stock FMU there is a hose which goes to a dial switch. This hose is where the vacuum lines for the turbo will attach. Use the hose "T"'s and vacuum hose supplied to attach the boost gauge, boost controller and wastegate to this vacuum hose. The boost controller and wastegate must be in series. So this is what you will do. Take a "T" put it in line with the FMU hose, attach the open end to a hose and put another "T" on the end of that. Attach the boost gauge to one of these ports and the boost controller and wastegate to the other. Thats it, pretty simple. Use small hose clamps to make sure all the connectons are tight.

he says FMU but our cars dont have a FMU right?
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #11 ·
thats wat i said.
well im getting the vac lines from the nipple closest to the disty. and bov vac line right behind the throttle body.
 
1 - 11 of 11 Posts
Top