Mazda MX-6 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
333 Posts
Discussion Starter · #1 ·
Ok my car normally idles a little over 1k rpm's but just recently my idle started out normal and then will jump up to 2k and then drop and then jump back up immediatly and it will not stop it does not do this all the time it wont do it if i just start it up i have to have been driveing it for a while to get it warm and it seems to be more constant when the temp is really cold, i just replaced my VAF, and i started my car and then un pluged my tps and it made a very noticible difference so i dont think its that, i dont think its a heat problem becuase it happens when the temp is really cold out side even worse than when its warm, what i was wondering is could it be the IAC or what else could it be??? thanxs nik.
 

·
Registered
Joined
·
41 Posts
When my car did that, it was because I put on a new 65mm throttle body and slightly misadjusted the throttle stop limit screw. So the throttle was always slightly cracked -- and since I adjusted the TPS like that, it was reading idle but still getting a lot of air (even a small opening with a 65mm TB results in a lot of extra air). That was confusing the computer and it was doing the bouncing thing. So the lesson is: check for a vacuum leak (and the throttle limit stop screw), and adjust the TPS. Which happen to be the first things to check for ANY idle problems, as numerous threads will tell you when you do a search here or on probetalk.

Sucks how your first thread got highjacked though :).
 
1 - 2 of 2 Posts
Top