Mazda MX-6 Forum banner

1 - 20 of 1015 Posts

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #1
After many many posts here i decided to do a build thread. This is my way of keeping my mess to a minimum and trying to do my part to learn. So here goes, a little background on me and the car.
I have only owned a few cars and done a little work here and there with help from others. All i have learned has been on here and talking to others. I have only done a few projects on my own cars.I am a NOOB. not proud but beginning to learn.

My old car were '83 corolla 4speed (rwd hella fun for my first car), '83 cutlass sierra (only fun because you could bury the speedo and literally watch it disappear), '93 probe (2.0l mtx, short ram w/cat delete), '95 sierra (ext long bed 4x4 with a 454 and flowmaster), 91 civic (4 door dual resonantors, and fart cannon atx (never again)).

My car: '93 mx6 2.0l mtx.
Bought with a totaled title and lien paper work from a tow yard. It had a toggle switch with push button to start. No keys! It had 127k when i bought it, bald tires, worthless control arm bushing and broken exhaust tip. Crappy cone filter with the sensor for intake air temp electrical taped into the aluminum intake pipe. 40+ feet of speaker wire running through different panels and some damage to the drivers fender from running something over. Along with a toasted rear motor mount and burnt out angel eyes that had the housings melted. It had a painted valve, headers, short throw shifter and an attempt at 2.5" exhaust. pretty sure that covers it. I paid 1k.
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #2 (Edited)
Work as of today: had a friend fix the exhaust (he owns a shop) put in dual aero resonators and deleted the cat. I have put in new control arm, fixed the IAT and put new cone filter in. Pulled all "after market wiring" and rehooked up the stock stereo harness. Installed a sound system. Had keys made, put new tires on the stock wheels. Put in a rear poly motor mount, new projector angle eyes. I pulled the mud flaps on the front, pulled the decals, installed new tweeters, visors and found random parts that were missing (like the stock jack and tire changing stuff and power antenna). Pictures are in my sig for current stuff. will be posting new ones soon. One of the routes I am thinking about going is to buy a used motor and rebuild it. I can do a few things this way one is to take care of current issues like bad piston rings, a ticking lifter and learn how to work on my own bloody car! the small things i have done to keep it on the road lately is replace a hydraulic line that powered my clutch slave cylinder, replaced my intake elbow with a 45 degree spectre elbow and put a valve cover breather in since the stock elbow was cracked and some other random stuff.
 

·
Registered
Joined
·
32 Posts
Pics Pics Pics...

:tup: iKoN :tup:
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #4 (Edited)
pic of exhaust tip (dirty car too!)

Before new lights taken with my phone!


With badge removal, still gotta clean up holes (Most Current)
Old Headlights!


New Lights


Exhaust clip
Also in my signature. I swear i can never remember how to post pics on this forum!
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #6
They had pulled the ignition switch sylenoid (sp?) And had it wired into the plug that goes into the switch. Toggle switch for constant power or accessories and then the push button for when you would normally turn the car over. Simple 4 wire conversion if I remember right. I pulled it out when I bought the car cause I didn't want the guy to steal the car I bought from him since it had no keys at the time.

Sent from my HTC Glacier using AutoGuide App
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #7 (Edited)

please ignore the zip ties and off colors, just trying to keep up on upkeep right now. Got a front motor mount coming. can't wait to be able to not mis-shift cause of motor rock! btw the number wrote on e the plug wires was not me! I bought em that way.... Also remembered how to do the photo thing so pictures above have been changed from links.
 

·
Registered
Joined
·
2,331 Posts
I'll help out! :p

If you want to post a picture, right click the one you want (if it's on the INTERNET somewhere) and select "copy image address/location", then, when writing a post here, click on the little yellow square with the mountain in it (2nd from the right) and copy the image address in there.

As for videos, just copy and paste the address from the address bar. If it's a youtube video, the site will automatically show the video.
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #9
I'll help out! :p

If you want to post a picture, right click the one you want (if it's on the INTERNET somewhere) and select "copy image address/location", then, when writing a post here, click on the little yellow square with the mountain in it (2nd from the right) and copy the image address in there.

As for videos, just copy and paste the address from the address bar. If it's a youtube video, the site will automatically show the video.
thanks man i had gotten it figured out, when hosting on flickr i was trying to use the code they gave me figured out a different way to get it though. I'll try your shortcut next time.
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #11
yep.... wd40 quieted it down for 2 weeks! gonna try some tri-flow with teflon for bike chains, next (its what i have laying around).
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #12

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #13
Well installed the front motor mount today. had to file the holes out so it would accept the larger hardware of the King 6 Poly mount. But now it is a whole new car. When i looked at my old mount the rubber had started to separate in the center and the metal had actually started to crack at the welds. Oh yeah and i could easily twist the center part from side to side. I bet it was the original mount from 1993. this fixed my gear selection problem and my torque issues! Now i still have to find time to wire halos, install/wire fogs lights and fix my sub I blew it driving to portland with the windows down. oh well it was only and 8" jbl. now time to upgrade to 2 12" jbls.
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #14
Small update: Classes are almost over and work is winding down for the summer. This is good since I am in the midst of wedding stuff. My squeeky clutch is starting to get to me and i sprayed some white lithium grease on it only to get the can crushed in my back floor board the other night, and it not to work! That stuff is a PITA to clean up. I'm going back and forth on what to get for fall term. My bearing plates need replaced and so i was thinking this would be a great time to get some springs, strut bars and put in the plates, assuming my brakes aren't going out as well.I look forward to September for the wedding stuff to be over, a little extra cash and some time to work on my car. I gotta fix a few rusty spots and fill the holes from my badge removal.
 

·
Registered
Joined
·
12 Posts
Sounds good man, always good to see someone working hard on their car. I been saving money to finally get started on my project which I'll make a thread for. Just got a 2nd job to save up quicker for my KLZE swap.

My rear badges, I believe 'Mazda' and 'MX6V6' didn't come with the car, and the holes are still there, so I want to fill the holes and make it look very clean (rather than try to find the emblems and put them on, but I'm probably keeping the hood Mazda emblem cause the 93-94 Mazda symbol is pretty unique lookin lol) Post some before & after pics when you have it done, lookin forward to it!
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #16 (Edited)
I used some black silicone to fill mine temporarily. the permanent fix i am looking at doing is to weld the holes shut then primer and paint. luckily i need to primer some other spots otherwise i would just use bondo. The v6 is usually just a decal next to MX6 if i remember right. but i kept the badges just in case they would be needed for something some day.

edit: Hooked up the halos today, probably get a night shot tonight to post. some idiot (me) pulled the old halos in a hurry and both markers on the front were dead so i had to reconnect the marker light fixtures to the stock harness and wire in the new halos. not to bad took me like 35 minutes in the street.
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #17
Mounted the fog lights today. With my rear brake shoes going out and my sts coming out on occassion it looks like upgrades will be put off for a bit for preventative maintance. Come the end of the month i'll nave that stuff done. In short ralco sts, new brake shoes if not disc conversion, fogs wired in, holes filled from badge removal and rust prevention and, possibly new drivers fender.

Sent from my HTC Glacier using AutoGuide App
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #18
Small Victory: went to grants pass this weekend to visit my mother in law and her boyfriend with my wife. he had bought 50 lbs of r12 freon nearly 10 yrs ago at a garage sale and we charged up my ac system. Now i got ac. Friday before going south I put in new rear brake shoes and my brakes appear to be fixed now. So in two weeks i'll be ordering 2 12's, a ralco sts (fond one for $53 shipped), fog light wiring kit and looking for a drivers fender. I really am falling more in love with my car the more work that gets done to it!
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #19
Unfortunately the ac is dead again (not cooling), so i know i have a leak somewhere. looks like a project for next summer.
my most recent engine pic. This term gonna remove the Valve cover and re paint with black high temp paint, hopefully it wont flake like it did. possibly gonna vht tint my tails, spoiler light and side markers. I am ordering new mount inserts as the rear is going out (Gonna do front and rear at the same time this time!), pretty sure my passenger LCA is going out again (after 14k miles) probably upgrade to poly if this is true. Install new cap, wires, and plugs, and a passenger side engine mount as well as clean up my engine bay wiring. A recent pic of the car :
 

·
Super Moderator
Joined
·
2,148 Posts
Discussion Starter #20


I never wash this thing but i do know it's running pretty well lately (knock on wood) aside from a rotational grinding that comes and goes. Have a few minutes to look tomorrow after i install led tail light bulbs (all three) and re-run a ground (hope 4 gauge wiring is good enough!) and re run halos to get more power to them.
 
1 - 20 of 1015 Posts
Top