Mazda MX-6 Forum banner

21 - 40 of 1003 Posts

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #21
So I installed the LED's and ran the power and got power to my halos re ran. BElow you can see the pics I have a few problems though. I have a rear light idiot light on in my cluster. All my lights work but I'm going to assume the lower power draw causes the light to trip thinking a bulb is out. I was hoping adding a new line from the negative post on the battery to the inner part of the frame by the radiator and fender would help my my starter issues (turn key and nothing turn key and nothing turn key and engage, probably brushes?) but it didnt but it did help some of my idle issues concerning slowing to a stop or at a stop and pushing in my brakes. Still gotta figure out the drivers fog light, it has corrosion in the metal that hold the bulb into it gonna try and sand it to see if a better connection fixes it. i know it's getting power.

Pics i said....



 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #22
btw i would say the 50 led reverse lights were a good purchase for $8/ bulb but the 32led ($7.98 for 2)for the brakes lights were not so hot. wished i got a little more bang out of them.
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #23 (Edited)
Still using the LEDs, i have got to say I hate light bulbs, the cheap 5k fog light bulbs i got off of fleabay have both burnt out with the first one burning out after plugging it in and the second one with less than 1 hour. My rear idiot light stays on because of the leds. there is a resistor i can buy and put in to keep the idiot light off but the low current draw from the leds is causing it to think that a bulb is out. Getting crimps taken out of my exhaust tomorrow gotta order escort strut mounts today and soon buying some struts/springs. Pics tomorrow of my full exhaust set up!
last edit: my friend had a honda he f-d up the vht tint on the tails. he bought a new car (well was given to him) he's giving me the tint for my lights, so theres another thing i need to do now!
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #24

The old crimped pipe! Found out my exhaust is not 2.5 all the way back. Kind of a bummer but it still moves. Maybe over the summer i'll get a new tip and have the last section of it enlarged. It measures 2.25 now with a 2.5" inlet tip.
A close up of the worst crimp.

And finally my last discovery my passenger side motor mount!

I now have an awr side mount

A picture of my "Full Exhaust"

I may fix my dented header and oil pan but those are lower on the list of things to do right now, as i found my rear end link (stock) snapped off of my passenger side rear sway bar. This is the life of an mx6, when nothing is taken care of your car gets hashed and then it becomes one repair after another. Well thats where i'm at.
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #25

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #27
recieved, escort front strut mounts, altima rear endlinks and monday i should have dimas old set up on.monday or tuesday. tokico blues and i believe sprint racing springs. shouod be close to a 2.5” drop on the front and 2 or 2.5 in the back. if i can scrounge the money together a 19 or 16mm sway for the rear will go in at the same time as the rest.
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #28
Work List to be done:
Mate escort mounts to front struts
Receive Rear Contour Sway bar
Mate Altima endlinks to sway bar
Fix my leaking passenger tail light
Relocate Battery to trunk
and Relocate Cone Filter to stock air box Inlet in the fender.

Should be done in may My current schedule sucks and school is kicking my butt. 40+ hours on campus and then homework and life allows no time for my car, but I'm gathering quite the set of upgrades....
i did take some pictures of the great look i have with stock suspension and 14" stock rims!



 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #29
Installed some cree projector reverse lights, the leak I had in my passenger tail light was a great excuse to try something new. These things are bright I looked into then while installing and blinded myself. Pics to come when its dark. I also ordered a cougar rear sway bar (17mm) to install this weekend.
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #30 (Edited)
Bought some Cree style led projector bulbs for my reverse lights....
They are bright as hell


I couldnt take a pic straight on because the camera wouldnt focus and just showed two bright lights.... to compare to LED's


these things are almost as bright as headlights! The last two photos were taken from the same distance only the led photo had a flash from my camera.
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #31
Cause I'm starved for attention I will post these on Facebook, Flickr, NW section and in this thread!
New parts installed:
Tokico Blues, Sprint springs and escort front strut mounts (bitch because you have to round file the opening to get our struts to fit) heres a little before and after session!








 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #33
Damn, those reverse lights are bright! The drop looks nice...
Thanks... They're 7mm Cree style projector bulbs... I wanna see what I'm running over before I feel the bump!
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #34 (Edited)


so... i added altima endlinks to the 17.10mm contour sway bar. the down side is its about 2 -3 inches longer over all than the mx6 sway bar. I made the mistake of attaching the bolts on the top of the frame attachments prior to the lower ones. i'm gonna have to re-try in the morning to hook up the bolts in a different order tomorrow. The skinny of it is it's in minus two bolts! pics in the afternoon of it installed properly but it's pretty hard to make this one move in the way i want it to. Should help with handling.

After 200 miles the new struts rock. I came off an on ramp yesterday and felt like i was doing 50mph looked down at the speedo and was doing 80mph. my stock suspension may have been a little worn out! my car no longer feels, or reacts to, the draft off of big rigs and no longer feels like its floating at "high speeds".
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #35 (Edited)
well I still have to center the bar on the car but it's close and i think i'll leave that till they align the car. but here is some install pics:




Theres still two weak points in my suspension and the number one thing that is gonna be changed is my tires. I'm still on stock alloys and running 195/65 14. You can definitely feel the slop when turning the wheel side to side.

All you need to know about installing the contour rear sway bar is that it is bigger, longer and has an odd bend in it.
To install you should get new higher quality endlinks (I used endlinks from a 1995 nissan altima), other than the optional endlinks, you should only need the bushings (mine came with them)

Tools needed: A 9/16" wrench, 15mm wrench, a 5mm allen wrench/key and a 17mm wrench.
It took me a hour and a half to install with my car sitting on the ground and having to saw off one of the endlink bolts.
Because it's longer put the endlinks on the bar off the car.
Then remove the old bar:
Remove the top bolt of the old endlinks then the two bolts holding the bushings to the frame on each side. the bar should "slide" out.
Remove the brackets that hold the bushings to the frame from the mx6 bar.

to install:
Place the frame brackets that hold the bushings to the frame on the bushings
Slide them in towards the center of the car you could probably approximate them by comparing the sway bars and matching them that way.
place the bar under the car, slide the endlinks into place and lightly thread the bolts on.
attach the bottom bolt into the brackets that hold the bushings into place then the nut on the top side.
(note: i did it the other way and i had to use c- clamps to get the brackets into place)
then tighten down all loose bolts/nuts and enjoy.
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #37
Gonna buy my friends wheels from him. They are for a 92+ 300zx tt. 16" X 7.5 with a 45 offset and 8.5 with a 35 offset. I gotta test fit them but should be a good deal for about $200 although i gotta replace the tires.
I ordered a set of m-edition tail that will be installed when i get them. Still have to do the battery relocate and pipe my cone filter into the stock air box hole.

I did a little more research on my car (vin check) My car is well traveled!
Bought at a dealership in Montana
Registered in Nevada, Florida, California, and Oregon.
Totaled (Apparently body damage, no airbag deployment) in California
Stolen in Oregon
Recovered in Oregon
Then bought by me. This poor car has seen more of the country then me!
Still gotta do a little more research to find out what all 46 items are on the vehicle history report!
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #38
recieved m-edition tail lights in the mail today, gotta install them, paint my valve cover, install a battery relocation kit, get a new fender and repair the rust damage on my sunroof, before Forumfest!
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #39
A new ass shot!
 

·
Super Moderator
Joined
·
2,131 Posts
Discussion Starter #40
Ran the positive wire to my trunk for the battery to be relocated. Ran into a problem though Where the f do i plug it in at? and where do people ground in the trunk? Strut, seat bracket? I'm looking to locate it on the driverside near the well for the tail light. Will post pics of my connections in a few.
 
21 - 40 of 1003 Posts
Top