Mazda MX-6 Forum banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
10,652 Posts
Discussion Starter · #1 ·
yup, i have a question :)

my fuel gauge no longer works. I'm assuming its directly related to the fuel pump swap (walbro 255) - as it worked great prior, and doesnt work now.

i did not touch the gauges at all.

anyways, it reads full, all the time.

check that.. it will most of the time read full.. it will randomly read 1/2 when i start the car (but if i shut it off and start again it will read full again)

it will also *sometimes* work, but is inaccurate. ie: my new "empty" is halfway between 1/4 and 1/2 tank (indicated)

ive been going by the trip odo, but i would prefer to fix this.

btw it worked before my turbo install and all tis related upgrades. (fuel pump being one of them)

the only fuel system modifications i have are the pump, which i am confident was installed properly, and there is nothing obvious under there that is disconnected or corroded, an FPR, and an FMU.

any ideas?
 

·
Registered
Joined
·
5,869 Posts
No passthru in the mx6, so prepare to drop that biotch :(
-Garrett

Although, if its actually related to the Walbro, and not coincidental, there may be wiring issues. Was the Walbro hooked up using any of the stock harnesses?
-Garrett
 

·
Banned
Joined
·
272 Posts
the walbro hooks up to factory wiring , as it direct replacement part , all the wires on the gas tank are 1 way unique connectors , meaning that they only hook up one way and only to its coutner part , there's no way to mess it up .

I'm no electronics wizard , Btu it reading high resistance when full or empty , my guess when full , there's got be a bda ground a pinched wire some were i did'nt see . I don't undersatnd why works sometimes ?
 

·
Premium Member
Joined
·
10,652 Posts
Discussion Starter · #4 ·
rotten97 said:
the walbro hooks up to factory wiring , as it direct replacement part , all the wires on the gas tank are 1 way unique connectors , meaning that they only hook up one way and only to its coutner part , there's no way to mess it up .

I'm no electronics wizard , Btu it reading high resistance when full or empty , my guess when full , there's got be a bda ground a pinched wire some were i did'nt see . I don't undersatnd why works sometimes ?
because, electrically, my 6 isthe gayest evAr! lol..

:)

oh - they wouldnt sell my xylene in the HD i went to??!?!

said need a hazmat license to buy it?

they showed me this stuff "xylenol" which contains xylene, and is fine for me to buy off the shelf but who knows whatever the fock else is in there. lol.
 
1 - 4 of 4 Posts
Top