Mazda MX-6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
384 Posts
Discussion Starter · #1 ·
My ZE is running pig rich. Fix it. Now.

Bwahahahaha.

But seriously, I saw a while back you had an aeromotive AFPR, is it any good? The ZE is running rich, so rich that I can smell it, but I haven't hooked anything up to it yet to get any numbers.

I have a feeling it's the stock FPR, as it's really the only thing I can think of since my ECU is already chipped and I've replaced O2's, spark plugs, wires, cap & rotor, done the HEI and external coil mod, etc.

So i'm stuck. I hate to pick your brain, but I know you have alot of experience with the K series. So any thoughts you have, i'm listening.

:tup:
 

·
Registered
Joined
·
2,219 Posts
My ZE is running pig rich. Fix it. Now.

Bwahahahaha.

But seriously, I saw a while back you had an aeromotive AFPR, is it any good? The ZE is running rich, so rich that I can smell it, but I haven't hooked anything up to it yet to get any numbers.

I have a feeling it's the stock FPR, as it's really the only thing I can think of since my ECU is already chipped and I've replaced O2's, spark plugs, wires, cap & rotor, done the HEI and external coil mod, etc.

So i'm stuck. I hate to pick your brain, but I know you have alot of experience with the K series. So any thoughts you have, i'm listening.

:tup:
It's the Xtremethings ECU. Mine was running rich also and that was the cause. I've replaced everything also but now I have a true ZE ECU and mine is running beautifully. I need to call Mike and let him know whats happening, see if there's anything he can do to fix the ECU.
 

·
Registered
Joined
·
384 Posts
Discussion Starter · #3 ·
It's the Xtremethings ECU. Mine was running rich also and that was the cause. I've replaced everything also but now I have a true ZE ECU and mine is running beautifully. I need to call Mike and let him know whats happening, see if there's anything he can do to fix the ECU.
Excellent thought noyz. I never actually thought about that. For some reason I haven't liked that ECU ever since I got it. I may just get the true ZE ecu and JE50 on friday.
 

·
Premium Member
Joined
·
10,652 Posts
an afpr isn't a bad idea, regardless.

but i *had* an aeromotive. some fucking thief popped my hood and stole it (only it) - lol. i made a post about it so i wont go into that again lol.

anyways- i loved teh aeromotive. very linear adjustments, even at the low end of the pressure spectrum (where most afpr's get "spitty"
 

·
Premium Member
Joined
·
10,652 Posts
i tapped my fuel rail, so i don't know which one fits... lol. i now have barbed fittings.
 

·
Registered
Joined
·
384 Posts
Discussion Starter · #7 ·
So I figured it out, just incase anyone was curious. I had a strange suspicion it had something to do with the throttle control system, so I took the voltage of the TPS with a multimeter.....and it turns out at closed throttle, the TPS was reading 5.00 volts. So I took the TPS off and saw the little mechanism on the inside was on the wrong side of the mating surface on the TB.

Long story short, it was backwards, causing the car to think it was WOT. Took the plugs out, and they are no longer soaked in fuel or smelling of fuel. And the exhaust smells normal again!
 
1 - 7 of 7 Posts
Top