Mazda MX-6 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Well, there isn't much to tell, I have a hand brake light on the dashboard that wont go off, any idea how to fix it? will it be cheap to fix at some garage as I am doing WOF in a couple of days..
thanks
 

·
Banned
Joined
·
420 Posts
i had problem with my brake light comin on as well, but i found out that my hand brake cable was really tight, so when my rear brakes pads got low it was actually pulling the cable, so check your rear brake pads to make sure there is some left, check brake fluid level and top it off, and only other thing u can check is make sure your hand brake cable is caught on something or too tight makin it stay on.
 

·
Registered
Joined
·
2,061 Posts
it souldnt come on because of rear brake problems. there is a sensor right in the level that makes the light come on, it will also come on when your brake fluid is low
 

·
Premium Member
Joined
·
5,344 Posts
When mine came on in my old MX6 we found a leak in my rear brake lines. Needed them replaced from the master cylinder back.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #8 ·
Hmm, my brake fluid is completely full as I checked, so the problem is elsewhere. So what should I do next, take apart the cover where handbrake is? Will I be able to do fix anything from there? sorry, I am not really a mechanic...I've been told it might be that some sort of plates don't come together because of dirt and things, so if I clean those it should be ok?
 

·
Registered
Joined
·
42 Posts
I have had to Bleed the system sometimes bubbles cause the light but this is rare. I would look at the cable maybe its not releasing in one spot and catching on something. Just follow the cable.
 

·
Registered
Joined
·
288 Posts
i'm having the same problem. initially on moderate to hard braking my light would come on and then when i released the brakes and accelerated it would turn off. last night it came on and wouldn't turn off again. my brake fluid level is just above full. as per a suggestion in another thread i unplugged the level sensor on the resevoir and the light went out. it still comes on when the hand brake is applied. so what does this mean? do i have a faulty sensor? i don;t thinkg the lines need to be bled because when i finished my engine rebuild i bled all 4 brake lines.
 
1 - 10 of 10 Posts
Top