Mazda MX-6 Forum banner
1 - 16 of 16 Posts
G

·
Discussion Starter · #1 ·
The automatic transmission shifts very hard on my 93, especially from first to second. Anyone has this problem?
 
G

·
Discussion Starter · #2 ·
yeah i have it also. it feels like the car is goin gto go out from under you it jerks so hard. my tires squeek out of second, with my auto
 

·
Registered
Joined
·
3,167 Posts
djboner said:
The automatic transmission shifts very hard on my 93, especially from first to second. Anyone has this problem?
And you aren't seeing any check-engine or Hold light indicating an engine/transmission control problem?

I ask because if any of:

- knock sensor (code 5)
- VAF (code 8)
- coolant sensor (code 9)
- intake air temperature sensor (code 10)
- throttle position sensor (code 12)

code are set, the PCM will not perform a torque reduction during shifts, resulting in hard shifting. Also, does it do it only when cold? I seem to recall that the torque reduce logic doesn't occur until the transaxle fluid reaches a certain temperature...

If the PCME hasn't logged any of these codes then you might consider having the transmission line pressure checked.
 
G

·
Discussion Starter · #5 ·
The only time that my check engine light comes up is after I've been driving on the freeway at a steady speed for a few minutes. The hold light doesn't light up while driving.
 

·
Registered
Joined
·
216 Posts
ok im not sure which one it is!

I use to have a 93 and it was auto,and every time it would go from 1-2 it would grind pretty hard-so then later on when i got my 95ls (auto/soon to be manual) i noticed that it didnt do the same so i asked mazda what the deal was and they told me(this is where i forget) that the 93 tranny was designed by "mazda" and that the 94-97 were all designed by "ford" or i could be the other way! but anyhow they said that its normal for this to happen the only problem with the 93 tranny that i know from experiance is that its very weak.
 

·
Registered
Joined
·
283 Posts
yeah i also have a 1993 mx6 v6 an auto and my shifts rough to like its going to come out from under and it peels out in second, my tranny blew and i had to rebuild it i should have changed to a level 10 but i was stupid. There trannys are weak the stock ones so be careful
 
G

·
Discussion Starter · #8 ·
same prob

I have had the same problem with my 94, and its a four cylinder, It is an automagic(unfortunatly) but i got such a good deal on the car i couldn't pass it up. Well its only got 60k on it and it shifts the same way into second sometimes chirping the tires. I talked to my dealer and had them pull the codes on the tranny and they said that it was burnt up. Well the hold lite was flashing and i was continuing to drive the car. Then the light stopped flashing and the car shifted fine. Now the lite is back on and it shifts hard. It could be your shift solenoid which is internal and it could also be partly due to the torque converter. All mazdas have numerous tranny problems from the info i'm getting here, they have wiring harness probs, shift solenoid probs, pressure probs, and torque converter problems, GET IT LOOKED AT NOW B4 ITS TOO LATE. YOU SITLL MAY BE ABLE TO SALVAGE IT without spending to much in the long run
 

·
Registered
Joined
·
5 Posts
93 mx6 hard shifts

My wife's 93 LS would catch second turning out of our driveway. It was also losing coolant every now and then. It would take a while for it to actually overheat.

Ended up needing a radiator. The tank or line was busted inside and coolant was getting into the ATF cooler. Put a new radiator and flushed the tranny and everything works great now.
 

·
Registered
Joined
·
841 Posts
hahaha nice thread bump!!!
 

·
Registered
Joined
·
1,525 Posts
Wow, 8 year old thread bump FTMFL :( I think this might be a record.
 

·
Registered
Joined
·
44 Posts
I had to come out of retirement for this one.

Suprised to see "falconsixty3 has just replied to a thread you have subscribed to entitled - Hard shifting on automatic transimission - in the 2G MX6 General forum of MX6.com." in my inbox of my old email account.

NICE!
 

·
Registered
Joined
·
91 Posts
Try putting a intake for the auto i have on there and i think is b/c airlflow it feels alot better shifting... Give it try....
 

·
Registered
Joined
·
70 Posts
I had this problem on my old Grand Prix and it was the torque converter. Don't know anything about the automatic trans on the MX-6 though.
 
1 - 16 of 16 Posts
Top