Mazda MX-6 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
hey guys.. i have a bit of a problem.. lately my needle seems to be runnin high.. but it does not overheat.. i changed my thermostat and water pump and there are no leaks from any of the hoses.. and sometimes. just recently when i turn on the car white smoke comes out..now does this mean i have a cracked head gasket or something like that, and if i do, will it eventually overheat if i dont monitor the water and what is the cost to get it fixed??? please help me out
 

·
Registered
Joined
·
3,092 Posts
oh damn... this could be bad...

are you sure ot only does it when you turn? this could be bad...

the thing about a bad head gasket is... not only does the coolant not get to where its supposed to go, but... when it gets into the cylinder, it burns REAL hot... and yes, coolant comes out of the tailpipe in the form of white smoke...

i hope you have a 4-cyl...
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3
yeah it only happens when i turn on the car... but the weird things is that the needle rises and comes back down.. i even let the car run with the ac for a good 20 mins and the needle didnt rise.. it stayed in the normal position... so if it is the head gasket.. will it eventually overheat?? i mean can i drive it like that and how much will it be to fix it?? thanks!
 

·
Registered
Joined
·
3,092 Posts
OHHH.....

when you turn ON the car... sorry i misread that...

if its not overheating, it may or may not later...

the smoke wouldnt happen to have a bluish tinge to it, would it?
 

·
Registered
Joined
·
53 Posts
Discussion Starter #5
no it doesnt have a blueish tint to it.. by any chance will this effect the performance of my car?
 

·
Registered
Joined
·
3,092 Posts
it might affect performance.. chnces are, it will. do a compression test...
 
G

·
my 93' 626 does the same thing, but not when i start it. it happens after i let it idle for a minute or so, ill step on the gas, and a puff of smoke will come out. it has a slightly bluish tint, but it is mostly white...and it smells like gas, not oil! lol. i think its a combination of my injectors leaking, and the valve seals are going out. it has 150k on it, and still runs damn good. the oil level stays pretty high, eats about a quart every 1700-2000 miles. the coolant has always been in the same spot, but the temp fluxuates a lot. it goes from about a little below half, to almost 3/4...then one tap of the gas for 10 seconds going down the road, and its back to normal....beats me. as long as the damn thing keeps driving, im happy!
 

·
Registered
Joined
·
53 Posts
Discussion Starter #8
well my car is going to the shop tom... im prayin its nothing serious but im prepared for the worst.. ill let u guys know what it is...
 

·
Registered
Joined
·
3,092 Posts
its not the head gaseket... head gasket will only blow smoke out the tailpipe after the car gets warmed up (after the Tstat opens). tell us what the mechanic finds...
 

·
Registered
Joined
·
53 Posts
Discussion Starter #10
well i got my car back a lil while ago and everything seems to be fine now.... the mechanic told me that one of my heater hose was busted so that caused the overheating... what baffles me is the white smoke... i changed the seals when i first bought the car last july so i dont think that i could be burning oil... i just dont get it:rolleyes: any ideas??????
 

·
Registered
Joined
·
3,092 Posts
SHINER said:
and there are no leaks from any of the hoses..
uh huh...:D

is it still blowing smoke? which 'seals' did you replace?
 

·
Registered
Joined
·
53 Posts
Discussion Starter #12
the valve cover seals... as of the smoke.. not lately
 

·
Registered
Joined
·
3,092 Posts
pull your spark plug boots and check for oil. if theres none, then youll be good to go for a while...
 
1 - 13 of 13 Posts
Top