Mazda MX-6 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
Hi guys/gals, it's been a while since I posted here.

I recently put my 626 back on the road and the heater control has stopped working. The heater works but when I move the slider nothing happens, it always blows from same vents. I have a leak somewhere so the windshield really fogs up bad when it rains.

Any clues as to the most likely cause? How do I take the dash apart to see what is going on back there?

Thanks,
Joe Mc
 

·
Registered
Joined
·
102 Posts
Hey,

I've had the same problem with my 6. I pulled out the heater control unit and found out that a cable runs from the unit to flaps controlling the vents and such. The reason that the switch wasn't working was because the cable was disconnected at the flaps. Just attach it back in the correct placement and everything should work fine
 

·
Premium Member
Joined
·
7,327 Posts
Remove the glove box and passenger side undercover and you should be able to access the control wires for the DX/LX manual climate control. Apparently they disconnect without tools.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #4 ·
Thanks guys, that is exactly the info I needed. It'd be nice if it's just the cable disconnected. :)
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #5 ·
Ok, I got the dash apart. I can see where the cables go for the temperature and the fresh-air intake but not for the heater mode. I can see where the cable attaches to the slider but where does the other end go? It appears to go straight back towards the firewall but I can't see what it attaches to.
 

·
Registered
Joined
·
29 Posts
The control for the heater vent selection is on the left side of the heater box near the driver's feet. Remove the panel next to the accelerator (3 push/pull fasteners) and you will see a round plastic wheel (probably white). The cable connects here. This is the easiest of the three heater cables to reach and connect.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #7 ·
Thanks sriramgiri, I don't know how I missed that before. Problem solved.
 
1 - 7 of 7 Posts
Top