Mazda MX-6 Forum banner

1 - 20 of 94 Posts

·
Registered
Joined
·
392 Posts
Discussion Starter · #1 ·
hey guys! i'm doing a hei mod cause i think the ignitor in my disty bit the big one, which probably have been the problem with the car from the get go. it would start but it would take a very long time to start. it would take my almost up to 20 cranks just for it to start. i tried to start it yesterday and all i got was two very slow cranks, a click and a wooosh. the spark plugs, spark plug wires, disty cap, rotor, even my fuel filter is new. the only thing that haven't been changed is the distributor.

well anyways, i have the diagram and instructions for the mod but i'm confused on something...when i install the hei do i install it looking at the wire connector form the back or the front? if its the front than my wires are completely different. looking from the front of the 6 pin connector instead of having a blue/orange pin 6 i have a black/red pin 6 and looking from the front of the 3 pin connector instead of having a black/pink pin 1 i have a yellow pin 1 and pin 2 is the black/pink instead of yellow green...i'm using the joe bialy hei diagram by the way any thought on this guys?
 

·
Premium Member
Joined
·
5,344 Posts
Moved to 2nd Gen forum. Should get more help here.

Wish I could personally help you, but I have never done the HEI mod, I just replaced with a new distributor.
 

·
Registered
Joined
·
392 Posts
Discussion Starter · #4 ·
Moved to 2nd Gen forum. Should get more help here.

Wish I could personally help you, but I have never done the HEI mod, I just replaced with a new distributor.

lol...i would have to but i don't have 300 bucks right now to replace it so i'm doing the cheapest and most reliable mod ever to fix it!

glue i'll get back to you on that cause i'm currently at work!
 

·
Premium Member
Joined
·
5,344 Posts
You should join Mazdaspeed Motorsports. I bought mine direct from Mazda for $182.
 

·
Registered
Joined
·
752 Posts
Its from the front, i didnt even look at the colours of the wires :lol: it is a very easy mod
 

·
Registered
Joined
·
392 Posts
Discussion Starter · #7 · (Edited)
You should join Mazdaspeed Motorsports. I bought mine direct from Mazda for $182.
lol! i should join huh! i'm still going throw with this though, if worse comes to worse than i'll just replace it. thanks I4...oh by the way, i apologize about the thread on the wing. i was under the influence!

Its from the front, i didnt even look at the colours of the wires :lol: it is a very easy mod

thanks, was just trying to make sure. i don't wanna have any mistakes. i'll be hooking up everything tomorrow, also the diagrams show that hei "c" connects to pin 2(the wire is yellow on my disty) which is ig- correct? well that yellow wire is for the tach signal. i know this because i went on the12volt.com to get a wiring diagram for my stock security system and it shows the yellow wire being the tach signal, i even have an aftermarket tach hooked to that wire so in my opinion the green wire would be the ig- correct me if i'm wrong!


if you type this in the search button this is where i got it from:

Re: $20 Ignitor Replacement/upgrade

it was reposted by ruubstr94ls

the link to the diagram i'm using is in this write up!
 

·
Registered
Joined
·
752 Posts

·
Registered
Joined
·
392 Posts
Discussion Starter · #11 ·
I just did this mod like two days ago... whats the point of cutting the strap inside of the distributor?
I never did it, and the car runs...
because that strap is grounded to the ignitor in the disty and since your using a different ignitor, if you don't remove it it may still ground to the ignitor in the disty causing the car not to start properly or not start at all.
 

·
Registered
Joined
·
392 Posts
Discussion Starter · #12 · (Edited)
hey guys, thought i'd give you guys the update on whats going on!...the mod didn't work. it fires it just won't stay started, so its probably my distributor. i'm getting no codes from the cam sensor so it may be the coil. i have the jap distributor that came with the engine the only thing is i don't have the wire connector for it. i want to use it but i need the ze disty wiring diagram so i can determine which wire goes to which. and since i can't find the wire connector for which i thought i had...i think my brother throw it in the garbage when i specifically told him not to throw away any of the connectors...retard lol!...how else can i hook it up with a connector? or do you guys think that i should just replace it with a new a-spec one. i really don't wanna spend 300 bucks on a new disty but i will if i have to. the ze disty seems like a better alternative! what do you guys suggest?

oh and thanks to all that responded in regards to helping me...i really appreciate the help!
 

·
Registered
Joined
·
752 Posts
if you think it could be the coil use the cap of the j-spec dist and use a external coil
 

·
Registered
Joined
·
392 Posts
Discussion Starter · #14 · (Edited)
if you think it could be the coil use the cap of the j-spec dist and use a external coil
thats exactly what i was thinking. the problem with that is the cap for the j-spec disty was damaged badly and it doesn't fit the a-spec disty. neither will the a-spec disty fit the j-spec disty so this mod isn't going to work. what if i go all out msd ignition with external coil? hell if um gonna spend 300 dollars on a new disty, might as well spend it on something that counts rather than spending it on something that i really don't need
 

·
Registered
Joined
·
1,482 Posts
you need not disconnect the internal strap once you cut the Pin #6 BL/Orange wire which is the ECU pulse triggering the internal transistor that fires the coil... So it is redundant and bad for your disty if you cut that strap out you can never un-do that and go back to OEM. Solder joints inside there wont last i've experienced it.

Here is a clearer diagram which i take no credit for.



There are so many write ups on this topic it is not funny and it all depends on how you want to run things on your car.

Internal coil + HEI
Internal coil + HEI + MSD 6al or similar IG box
External coil + internal igniter (bad idea)
External coil + HEI
External coil + HEI + MSD 6al box
External coil + npn 3055 transistor + MSD 6al box
 

·
Registered
Joined
·
392 Posts
Discussion Starter · #16 ·
thanks for the diagram...i see why it won't start and what i did wrong, but uma just go external coil with msd and hei. less headaches. the wire that was suppose to connect to the w pin on the hei i didn't connect so thats why it wasn't working.....anyways..i'm just gonna upgrade the ignition while i can and not have to worry about internal coil and igniter anymore. does anyone know where i can get msd plug wires from? i don't think anyone sells them for our cars!
 

·
Registered
Joined
·
81 Posts
hey guys, i thought i'd re-post in here got no responses on my other post, my hei mod is working car runs good, drives perferct, i've checked the wiring numerous times but still can't figure out why my tack isn't working? i used the proper resistor, as far as i know or can remember( been a while since i did the mod) 1/2 1k ohm resistor is i'm not mistaken, tach at idle sits at 2500, under a regular load it creeps up to around 2800, but when i floor the thing it goes backwards and wraps back to zero?:confused: did i wreck my tach? this has had me confused for a long time, if anyone has any ideas or insight it would be much apprciated. thanks a lot. if not thanks anyways
 

·
Registered
Joined
·
1,482 Posts
what MSD plug wires? the spark plug wire set?

External coil + HEI



HEI in a box



Wires stripped not cut.


Wires soldered


Wires taped up


Test setup prior to installing a msd blasterSS coil
 

·
Registered
Joined
·
1,482 Posts
hey guys, i thought i'd re-post in here got no responses on my other post, my hei mod is working car runs good, drives perferct, i've checked the wiring numerous times but still can't figure out why my tack isn't working? i used the proper resistor, as far as i know or can remember( been a while since i did the mod) 1/2 1k ohm resistor is i'm not mistaken, tach at idle sits at 2500, under a regular load it creeps up to around 2800, but when i floor the thing it goes backwards and wraps back to zero?:confused: did i wreck my tach? this has had me confused for a long time, if anyone has any ideas or insight it would be much apprciated. thanks a lot. if not thanks anyways

How is your ignition wired up?
Which one of the following fits your setup?
Internal coil + HEI
Internal coil + HEI + MSD 6al or similar IG box
External coil + internal igniter (bad idea)
External coil + HEI
External coil + HEI + MSD 6al box
External coil + npn 3055 transistor + MSD 6al box
 

·
Registered
Joined
·
81 Posts
running external coil + hei
 
1 - 20 of 94 Posts
Top