Mazda MX-6 Forum banner

1 - 4 of 4 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I decided to clean out my intake today. I spent three hours doing it. I think that I made a mistake in spraying Carb cleaner (what I was using to clean it) into the throttle body. It was a real bitch to start the car and know it idles ROUGH, and sometimes misses. The car is totally undriveable. How do I fix this???
 

·
Registered
Joined
·
449 Posts
it was real hard to start because the engine was flooded. It is the same when you use air intake cleaner.

I can't help you much about the rough idle and missing. All I know is that carb cleaner eats the teflon and other miscellaneous coatings in the throttle body/intake.

Double check the ignition wires (may have gotten loose)
Make sure the boot on the TB and VAF is tightened.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #3
TRY THIS

TAKE SOME WD-40 WITH THE CAR RUNNING, SPRAY A LIBERAL AMOUNT INTO THE TB, WORK THE FLAP WITH YOUR HAND, ALSO USE THE CARB CLEANER IF THERE IS ANY LARGE DEPOSTS OF CARBON LEFT, BUT ONLY WITH THE CAR RUNNING AND IN SMALL AMOUNTS. IT SOUNDS LIKE THAT THE EXTRA FLIUD DIRED INSIDE ON THE INJECTORS AND TUBEING. THE WD-40 MIGHT BREAK IT LOOSE. NEXT TIME USE IT WITH THE CAR RUNNING...GOOD LUCK, ALSO CHECK THE AIR BOX....})
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #4
I took 91mx-6's advice and sprayed a half can of WD-40 into the TB. Ran a little better so I ran a bottle of injector cleaner through on a quater tank of gas, after a hour of driving the response and power is much better now- better than when I started this whole thing. Thanks for the help
 
1 - 4 of 4 Posts
Top