Mazda MX-6 Forum banner

1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
I've a 95 2.5v6 MX6 133000 miles which is suffering from a lack of top end speed. The symptons are,
* won't go faster than approx 105mph
* appears to being limited at around 5000 rpm.
* up to 5000 rpm/100mph every thing appears normal, i.e. it's quick.
* it will go above 5000 rpm while in neutral.
* it just passed it MOT emiissions test.
* I can't determine whether my fuel comsumption is up or not.

It used to do 137 mph happily, it's been serviced every 9000 miles by a Mazda dealer. According to mazda the car is one of the best they've seen.

The problem came into being not long after a service and spark plug/lead change, and I touched 7000 rpm.

I've taken it into Mazda (synomyn for bills!), had it on the computer and they can find nothing wrong, infact they seemed to be surprised that I wanted it fixed?????

Does anyone have an idea on what could be causing the loss of top-end performance. Any help would be appreciated.

Also I'm suffering from the dreaded 126000 miles tapping, will this damage the car? I don't want to sort that (i.e. spend more money), until the performance is back up.
 

·
Registered
Joined
·
1,769 Posts
Try taking it to a preformance tuning place m8,
A lot of the dealerships are halfwits and wouldn't know how to tune a 1 string fiddle, think what they said to you :).
They said there is nothing wrong!, but the bloody thing won't go over 105MPH if that is the case then there is DEFF something wrong m8, as a guess it could be quite a few things < top end fuel starvation, a prob with the ecu, as I said it is better taken to someone that knows how to tune a car m8.
Lets know how you get on.

l8trz...
 

·
Registered
Joined
·
26 Posts
My car has similar problems and the engine on occasions in 3rd and 4th will not rev much above 5,000 rpm.

This tended to happen in the very warm weather and never happens in the cold. On the whole my MX6 goes like a dream in the cold damn air and revs nicely into the red without any issue. Chasing a Boxster in these conditions I managed to get 146mph up on the speedo, so I think my 100,000 mile MX6 is still going rather well.

If you car does this all the time I would check the spark plugs and clean out any oil in the wells, also check your HT leads as these do cause many problems on the MX6. Last of all it could be down to fuelling, so it may be worth as mentioned taking the car in for a tune up.
 

·
Premium Member
Joined
·
3,844 Posts
Hi don

It could also be as simple as a vacume leak that could be why it is ok with no load (neutral). I think you would feel a missfire if it was the plugs and leads.

As for the tapping.

Mazda dont use fully synthetic oil so I suggest Mobil 1 0w-40 or Comma 5w-40 fully synth But use the oil filter from Mazda not anyone elses. that should reduce your noise. but beware the thinner oil can produce a few leaks in old gaskets. but if youve had your services at mazda you should be fine. I use Mobil 1 but am going to use the Comma next change ( think the 0w-40 is a bit too thin)

Hope this helps some

dave
 

·
Registered
Joined
·
3,167 Posts
Ensure that the #2 VRIS is opening properly at 4250 and staying open. If this remains closed, power output above 4250 will suffer.

Check the exhaust for damage (e.g. crushed areas reducing flow.)

The catalytic converter may be plugged, your MTO emissions pass notwithstanding.

Pull a plug or two after one of these runs (let the engine cool a bit...) What's the colour? Any indication of fuel starvation? (plug insulators white-ish?)

If none of the above check out, consider having the cam timing checked out.
 

·
Registered
Joined
·
641 Posts
I have the same problem, how do I check to see if the #2 VRIS is opening and staying open? Even with my mods I can't get over 110 mph, though I really get up there with a quickness!:D
 
1 - 8 of 8 Posts
Top