Mazda MX-6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
heres the deal folks. i was driving to band practice and my 93 2.5 liter mx6 stopped on the highway. i pulled over and it would start back up again after a few minutes (didnt miss out either), then it would die and it finally quit starting. It seemes to fire on one cylinder, one time after its been sitting for a day. I changed out the ignition module, rotor, distributor. It has spark and it has fuel. My guess is its the crank position sensor and after purusing this forum have printed up the procedure and codes to check for that today after work.

Does anyone have any other ideas as to what i might chase after?
 

·
Registered
Joined
·
1,646 Posts
Haha, dropping someone off from band practice, my crank position sensor went out.

Sounds like it though. Does it run longer before dying out if it's left alone for a longer period of time? The firing up and dying right out sounds like it.

And I read somewhere that the speedo will be off/not read when this goes out sometimes. Happened to me, any problems to you?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
i didnt notice the speedo not working - not to say that it doesnt. i forgot to mention that i also checked the timing yesterday - it was fine.

heres another bonus - i took the ingnition control module out which was a borg warner part covered under warranty and left it on the front seat of my truck. two days later the truck burned to the ground (google ford cruise control recall) and guess who wouldnt take the part in for warranty swap?
 

·
Registered
Joined
·
1,646 Posts
Yeah, mine worked sparratically. Still doing it, which worries me...

Regardless, the ignition control module of the 6, or the Ford? Really sucks either way...
 

·
Registered
Joined
·
941 Posts
im occasionally throwing a code for a crankshaft postion sensor and sometimes the idle will get really low and die most of the time its ok though. And sometimes my speedo wont work at first but once the engine heats up it will start working
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
UPDATE!!!!! my '6' is giving me a code of 18. which is not a valid code per my shop manual and the list of codes i downloaded from this site. I also read that if you have a manual transmission (which i do) that you have to use a scan gun to retrieve the code.

any truth to that? does anyone know what code 18 is for a 93 mazda mx6 2.5 liter?

thanks

matt
 
1 - 6 of 6 Posts
Top