Mazda MX-6 Forum banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
I'm in France and there is no board in my country to speak about my car. sorry, my english is not very good.
I bought my mx6 V6 1993 in november 2000.
Monday, I was on highway at 130 km/h (~ 80 miles) and suddenly, the engine stop. I stop the car then I start of the engine and things were normal. then I go.
Tuesday, It happens the same problem at the same place. I make 50 miles a day and it did one time only always at the same place. I was really surprised.
and wednesday, again the same problem at the same place. the road mount and when I arrive above the engine stop. I don't understand. Also my handbrake is more relaxed than the normal. Is this in comparison with my problem ?
please could you help me ?
thanks.
 

·
Registered
Joined
·
3,167 Posts
chrilerr said:
I'm in France and there is no board in my country to speak about my car. sorry, my english is not very good.
I bought my mx6 V6 1993 in november 2000.
Monday, I was on highway at 130 km/h (~ 80 miles) and suddenly, the engine stop. I stop the car then I start of the engine and things were normal. then I go.
Tuesday, It happens the same problem at the same place. I make 50 miles a day and it did one time only always at the same place. I was really surprised.
and wednesday, again the same problem at the same place. the road mount and when I arrive above the engine stop. I don't understand. Also my handbrake is more relaxed than the normal. Is this in comparison with my problem ?
please could you help me ?
thanks.
Bonjour chrilerr,

Try going to my web page (see sig) and clicking on "Disty Fix" for the likely answer to your problem.

In short, the igniter in the distributor is likely going bad, causing loss of spark (hence the engine stall). It will likely get worse over time, with the stalls occuring more and more frequently.

For the handbrake, check to make sure the parking brake mechanism in the rear brake calipers is not frozen. Also, check the thickness of hte brake pads on the rear brakes.

Good luck,
 

·
Registered
Joined
·
26 Posts
i had my engine stopping in the middle of the highway last friday. i was going at like 120 km/h and then all the sudden, rpm to 0... pretty messed up. if i wasn't on the first lane, i would have been stuck in the middle of the highway... hell.
i pulled over and managed to restart the engine. went straight to my mazda dealer and he told me prob. distributor problem and quoted me roughly for $600. i never go to that dealer shop newayz tho. they r the closest one but they alwayz try to rip me off.
dono if it's creditable but he said it could have happened just cuz of the weather. because it's still winter up here in TO and that day, it was so warm. i need to check it out more bout it~
 

·
Registered
Joined
·
212 Posts
I had the same problem and my dealership fixed it for free! It has something to do with a bad computer chip that controls the distributer somehow. I don't know what the exact name for it is, I'm sorry. You should definitely find out if that is your problem though before you pay all of that money. I hope this helps. :)
 

·
Registered
Joined
·
26 Posts
GirlRacer!!!
Would it be possible for you to find out what it was? I would really really appreciated. After paying for a new set of cooling system (my old waterpump leaked and on) I can't afford another $600!!! Thanx.
 
1 - 5 of 5 Posts
Top