Mazda MX-6 Forum banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
My 96' mx6 was working fine until three days ago, i smelt electrical burning and smoke poured from behind my dash. Since then no smoke, but now and then the burning smell returns momentarily.
Ive had mazda look at it and have turned up nothing. Im an auto electrician and Im stumped. Anyone have this happen to them, or any ideas?

please e-mail me [email protected]
 

·
Premium Member
Joined
·
7,196 Posts
Is it just coming from the vents, or is it from all around the dash? I've had some come out from where my radio was, but that was over a year ago, and still haven't had a problem from it. I've also had it come in from the vents after high speeds, but from the engine.

Does the burning smell come only after driving? I have the same thing, and also no problems found, a long with my brother's 626.
 

·
Registered
Joined
·
384 Posts
If u have an after market CD player it could be that, i had something burning the other day, smelled like my clutch at first but it turned out to be my CD player, some of the wires were touching the back part where the power runs and it was melting the wire covers, so i just moved everything abck and no more burnt smell
 

·
Registered
Joined
·
2,044 Posts
recall on very early MX-6's

Hello Mark,

Have tried calling you a few times without success.

I dug out the letter from Mazda UK about a wiring recall and I don't think it is related to your smoking problem. The wiring fault is in the engine bay area by the radiator and was cured by fitting a shield of some sort (Mazda would do this FOC). It only afflicted the very first cars, and not your 1995 model.

Keep us posted.

regards,

Ian Chequer
 
1 - 4 of 4 Posts
Top