Mazda MX-6 Forum banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
i bought a 93 mx6 about 8 mos. ago and it has ran like a eam but the other day it just decided not to start. we knew it wasntgetting fuel and changed the filter that didnt solve the problem next step is the fuel pump however i have a shop manual on the car and it says youcan tae a piece of wire from the fuel pump fuse to a ground and forc the existing pump to work , my question is does egi stand for fuel and how do you get the white cover of the fse block of after you get the black one off? and does anyone know if ths will actually worl and if not how much is a new fuel pump and how difficult to install?
 

·
Registered
Joined
·
2,116 Posts
im confused as to what youre trying to do? if youre trying to make sure that it is the fuel pump, get in your diagnostic box and cross the f/p and gnd pins with a piece of 22 guage wire or a paper clip. turn your key to the on position and walk to the back of the car and listen for the fuel pump. you may have to open the fuel lid and stick your ear to the hole or stick your head under the car to listen for it. if you can hear it pumping it works if not, you either have a bad fuel pump or a problem with the wiring.
 

·
Registered
Joined
·
3,432 Posts
no start

Make sure to doublecheck all the electrical connections, fuse, relay, etc. for the fuel pump. Then if you still don't hear the pump running, try as Aussomea suggested.
 

·
Registered
Joined
·
2,664 Posts
I have one that works for sale for cheap :D
 
1 - 4 of 4 Posts
Top