Mazda MX-6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
My 94 LS since i've purchased it has had what would seem a very weak exceleration problem and the lady i purchased it off of said her mechanic said it was a bad fuel injector thats what caused the light flutter while excelerating and rough idle at stops. Now what I'm curious is cant it also be because of placing the wrong kind of Spark plugs that could be giving it the rough idle and slow fluttering excel. cuz it sure feels like a miss fire ya know? any ideas bro?
 

·
Premium Member
Joined
·
3,602 Posts
Hi and welcome ..

Idle issues and misfires .. very hard to fix online due to numerous possibilities.. only thing i can say is .. hessitation during acceleration could well be bad gap'd / fouled / incorrect plugs amongst other things, but this would be the first place to check.
Rough idle then throws in items like, vacuum leaks, bad spark leads, cracked worn dissy cap, throttle settings, IAC valve, coolant level.. and on and on ..

Start with the plugs, check the gaps, ensure they are the right ones, clean em up and try again (if they are the right ones). Also check for any codes even if the CEL light has not been on .. some do not permenently illuminate the CEL.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
okay. so i checked the plugs and they were infact the wrong ones and have replaced by new and correct ones and properly gap'd etc. but exceleration problem still exists...And CEL is not on either. gonna get throttle checked and cleaned. Oddball have you ever come across a bad EFI b4?
 

·
Premium Member
Joined
·
3,602 Posts
by EFI i assume you mean the fuel injection rails ? injectors can go bad/blocked, you can check them electronically off the car.

I would first still check the ECU for any codes and ensure the spark leads, distributor cap contacts and rotor arm are good.
 
1 - 6 of 6 Posts
Top