Mazda MX-6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter · #1 ·
for some strange reason all of a sudden i noticed this. i turned on my a/c and inside the car you hear this hissing sound(you can hear it very well because the dashboard isn't on). it sounds like a vacuum hose or something sucking in air, but i wasn't aware of anything like that in the car. it only happens when the a/c is on though obviously. when you turn it on then you get this weird rattling/clicking from the engine bay, its very very fast, and this only happens at idle. if i give it gas it will stop.

WHAT THE HELL?
 

·
Registered
Joined
·
2,064 Posts
Does the hissing sound coincide with the moment the compressor engages? That's likely due to low refrigerant; the hissing coming from the evaporator.

Listen for the compressor rattling when it first comes on as well; the rattling you hear is likely the compressor. They are known to get loud when they start wearing, although it may still work perfectly fine.


Tyson
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #3 ·
i was planning on changing the refrigerant out this weekend anyways, hope this has something to do with it.
 

·
Registered
Joined
·
2,064 Posts
Why were you going to change out the refrigerant? It doesn't exactly get old/bad like oil. Does the 94 have R-12 or R-134a?

The only reason you should mess with it is if it's low, and then you need to figure out why it's low.

Tyson
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #5 ·
twas going to change out the refrigerant because i let some of it out when i changed my alternator on accident and it hasn't been real cold since.

the car came with a 134 system.

the moment you turn the a/c on the hissing starts and then the rattling, except like i said its not just a normal rattle its like a vibrating rattle its very fast. jsut started a couple days ago.
 

·
Registered
Joined
·
28 Posts
it does the same here

hi
i didnt notice the hissing noise but i definitelly hear that clicking noise when idle .... little step on the gas and it goes away .....
my a/c works great though ...
if yall gonna figure it out please post the cause of it .... and what needs to be done to get rid of it
thanks martin
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #7 ·
ok here's the deal.

when the compressor is low on the oil it will start making that clicking sound. it turns out i had a leak(bad shrader(?spelling) valve so my low side leaked everything out. when i replaced it(with just a bicycle valve i might add) and refilled the system everything went away. i would check for leaks somewhere, add some stop leak oil stuff or something...
 
1 - 7 of 7 Posts
Top