Mazda MX-6 Forum banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #2 ·
Hi, I'm Linda I have the same problem. The hold light keeps flashing. I don't have the owners manual, so can someone please tell me what to do.
 

·
Registered
Joined
·
164 Posts
ok the "Hold" was a safety feature for the auto tranny, if something was detected wrong with the tranny it would go into "default mode" and dissalow the gearbox to change to fourth gear. If this light is on or blinking, this means that you need to go try to pull some codes off your car, my car is doing the exact same thing and after doing a bit of research online I have come to the conclusion that the auto tranny for the MX6 is really bad, and not getting any better

Im not really sure how to pull codes so dont look at me :) im sure you can search it on the site. but yea, that means ur tranny is detecting something wrong. 9 times outa 10 its not something mechanically wrong with the tranny, its in the electrical system. Thats why you need to pull codes to see exactly what its doin, I know I will be doin that later today anyways, or trying to hah. Good Luck and I hope that helped!
 

·
Registered
Joined
·
178 Posts
befor u change ur tranny

ok, the computers in the 93 mx6 are also faulty. IF u get 3 codes- i dont remember which ones, but if u get these 3 codes (i think 17 is one of them), even after u reset ur comp, the problem "most probably is" with your computer and not ur tranny. take it to some shop that does these comp diagnostics and make sure its ur computer and not ur tranny. i had my tranny rebuilt but i was getting the same problems. turns out it was not my tanny in the first place, but my computer and this thing was printed in some obscure manual that the guy dug out and he did change my comp and i have had no problems since.................
 
1 - 4 of 4 Posts
Top