Mazda MX-6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter #1
Well tonight I gave in to temptation and turned up my boost to 17psi on my new turbo. I hooked up a DVOM to the O2 sensor to keep tabs on the air/fuel ratio. It stayed at or above .92 volts the whole time (except in 5th) leading me to belive all is well. All I can say is...HOLY $H!#!!!! Damn this thing really moves now. It pulls at the way to redline really, really quick ( to quick for the tires in 1st and 2nd :( ) In 3rd and 4th on the highway 110mph comes VERY quickly. I can't wait until the track opens again so I can see what it will run. I looked all around for someone to race, but couldn't find anybody. Oh well, soon there will be a 1st victim. I just hope my 170K motor doesn't blow before I rebuild a new one:)
 
G

·
Guest
Joined
·
0 Posts
How did you do that? Is it easy to do? i have an 89 mx6 turbo charged of course.
 

·
Registered
Joined
·
261 Posts
hey! thats some good work!

Is your engine stock??
(with 170k miles?? geez!)
If it is, I guess those things really are bullet proof!
 

·
Registered
Joined
·
1,426 Posts
cool

You should get one of those dual stage boost controllers from Dawes, so you can drive around on 12 psi normally, and then hit a switch for the 17 when someone wants to mess with you. That way you won't be so hard on the motor all the time. You could even rig up the switch to the switch blank next to the fog light switch (at least I have a switch blank there...)
 
1 - 5 of 5 Posts
Top