Mazda MX-6 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
449 Posts
Discussion Starter · #1 ·
And what do you use? I've used Red Line MTL with good results. Just changed w/ Mobil 1 until I can get some more Red Line.

156K on the original MTX and clutch w/ no problems. (replaced the slave cylinder on the clutch twice, though.)
 

·
Registered
Joined
·
45 Posts
I've never changed my transmission fluid. 141,000 miles - new clutch 20,000 miles ago.
 

·
Premium Member
Joined
·
3,962 Posts
Umm.. I've heard BAD stuff about using mobil 1 atf in our trannies. I forget the exact reason, but i think you might wanna do some more research on it.
 

·
Registered
Joined
·
449 Posts
Discussion Starter · #4 ·
I didn't use the ATF. It was the gear oil. BTW, man, that stuff STINKS! I will be putting the Red Line MTL in soon though. Found a place here in Atlanta that sells it, so I didn't have to pay shipping.
 

·
Registered
Joined
·
666 Posts
DON'T USE THE MOBIL 1 GEAR OIL! THERE IS A COMPOUND IN IT WHICH REACTS BADLY WITH SOMETHING IN OUR SYNCHROS!
From everything I've heard that stuff is BAD NEWS for our cars! Any other brand of synthetic is supposed to be fine, but, not the Mobil 1!
 

·
Premium Member
Joined
·
3,962 Posts
TexasMX6GT said:
DON'T USE THE MOBIL 1 GEAR OIL! THERE IS A COMPOUND IN IT WHICH REACTS BADLY WITH SOMETHING IN OUR SYNCHROS!
From everything I've heard that stuff is BAD NEWS for our cars! Any other brand of synthetic is supposed to be fine, but, not the Mobil 1!
I knew I remembered something like that. :)
 

·
Registered
Joined
·
449 Posts
Discussion Starter · #7 ·
Thanks guys! I'll change it this weekend back to the Red Line MTL! BTW, that stuff lasted me over 150K miles (oops!) and there is not the first problem with the tranny. I highly recommend it!
 
1 - 7 of 7 Posts
Top