Mazda MX-6 Forum banner

21 - 40 of 71 Posts

·
Registered
Joined
·
1,174 Posts
I have yet to find another guide that's so thorough though. If one were to follow this, it seems the main difference between the A and B versions is going to be in the ECU, so I could probably do everything exactly the same, just using the pin diagram for the 90-92.

Right?
 

·
Premium Member
Joined
·
5,011 Posts
if it helps you, n20 matt posted his wiring pinouts for his ms install into his 90-92 harness. he was runnin a v3, but im sure it wont take much to figure out how to wire it up to a 2.2
 

·
Registered
Joined
·
231 Posts
nice job dude. i just installed ms2 while you were doing all this.

i used the ms wiring harness though. made the engine bay clean as heel without all that work. leaves no unused wiring in the bay.

how is your rpm signal, mine sucks if i use a drill i can get 250 - 2500 really stable and accurate. but cranking i cant get a good stable rpm for [shizzle].
I had this problem with the 88, it would get tach signal if it was running but not during crank, we ran a 4AWG wire(i'd of used something smaller, but this was what i had laying around) from the negative terminal, to the chassis, to the engine, to the alternator brace, to the firewall then to the main ground on the MS unit. that cleared the issue up instantly.
 

·
Banned
Joined
·
27,927 Posts
My Megasquirt is done but it's already practically outdated.-PCB version v2.2 with an MS1 processor. It's been done for a long time but I made changes to the wiring harness and it's sat since. My tack welds ont he distributor popped off and I just never bothered to mess with it. :shrug:

I'm going to though.
 

·
Registered
Joined
·
1,969 Posts
My Megasquirt is done but it's already practically outdated.-PCB version v2.2 with an MS1 processor. It's been done for a long time but I made changes to the wiring harness and it's sat since. My tack welds ont he distributor popped off and I just never bothered to mess with it. :shrug:
Tack welds? what disty are you using?
 

·
Premium Member
Joined
·
18,203 Posts
Yeah, no kidding. All you need to do is remove the everything out of the GT Disty under the rotor except the bottom wheel, grind two teeth off of it and get it as close to the pickup as possible...until you feel the magnetic field when you spin the distributor shaft.
 

·
Registered
Joined
·
418 Posts
Discussion Starter #35
HopefullY it will warm up here soon...I just havent had the time nor the energy to stand out in the cold....

Everyone can use this and just change the wire pin-outs around to work with the 90-92, or just buy a 89 GT harness and use it. All the same really....

I will finish the tune soon though, before I drop in the FE3, that wasy it wont be another dead-end how-to...
 

·
Banned
Joined
·
27,927 Posts
Zach said:
go back to the turbo distributor :)
I'm going to I think. I haven't driven the MX6 in a year this March, besides last week when I pulled it into the garage. I'd go out and start it and rive it up and down the street but it hasn't had registration or smog in over a year. My plan was/is to get it legal again and start on my MS too. My harness is a little different than d0z so I think I'll take pictures and put it in this thread too.[/end hijack]
 

·
Premium Member
Joined
·
5,011 Posts
meh....brandon made 400whp for years on a ms1 2.2. it definitely ran and started up much better than my 1st gen on ms1 v3 on high res code. outdated or not, you can still get a very good tune out of it if you know what you're doing
 

·
Premium Member
Joined
·
18,203 Posts
depends what mods you have

Mine is pretty good and tuned very well for street.

running 550's, BP ignitor, TO4E 57 trim. I hit mid/low 11 AFR's up until 20psi
 
21 - 40 of 71 Posts
Top