Mazda MX-6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
666 Posts
Discussion Starter · #1 ·
WHOOP!
I'm so happy, I'm giddy.
For some unknown reason, one of my HLA's went A.W.O.L. The rocker arm was pushing against the valve spring, can't find the lifter, I imagine it's in the oil pan. That's why the car was running bad at high rpms. I guess at lower rpm's, the rocker pushed the spring down enough to support combustion, but, at higher rpms, all the air and fuel wasn't getting in like it was supposed to. Luckily, I had another set of lifters, and voila! It's running like a beast once again.
:D:D:D:D:D:D:D:D:D
I'm so excited, back to smoking Honda's and such.
The thing that makes me mad, is I didn't take the valve cover off sooner :rolleyes:
 

·
Premium Member
Joined
·
3,962 Posts
WTF??? How the hell did that happen? :) Well that's great that you figured it out. You were going crazy there for a while. I've never heard of anything like that happening before though.
 

·
Registered
Joined
·
36 Posts
good for you, mine's still f^%$ed i feel your happiness everytime i fix something, but it still wont work right.
 

·
Registered
Joined
·
287 Posts
Dude you gotta stop driving your car upside down!!! :)
Congrads though man!
 

·
Registered
Joined
·
1,855 Posts
Hell yeah!! Good job!!! You were just about ready to give up.

Now you can burn up the streets of Odessa!!! Give em hell man!!!

Find that lifter before it finds a way to make trouble!!
 

·
Registered
Joined
·
666 Posts
Discussion Starter · #6 ·
Oh yeah, Midland and Odessa won't know what hit them :D
As for the lifter, I think it fell down the oil passage into the oil pan. It won't hurt anything there I don't think.
Now, gotta get the turbo rebuilt and I'll be ROLLIN'!
 
1 - 6 of 6 Posts
Top