Mazda MX-6 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter · #1 ·
I need some help, i get some rattleling when i go over some bumps no matter what the electronic suspension says.....it sounds like something is loose but the noise only happens every so often....what could it be


thanks ratly
 

·
Registered
Joined
·
1,601 Posts
Before going any further take everything out of your trunk and car, then check under the rear carpet in both sidewells and spare well. Then drive it again. Most likely cause of this sound are endlinks. Next are struts that are worn and are hitting the bumpstops. Go from there.
 

·
Registered
Joined
·
1,640 Posts
Assuming the noises are coming from the front suspension, check all strut mounts. Just had new suspension installed. Mech didn't torque the upper strut mount enough and it came loose and rattled. Now the threads are stripped and it needs replacement. Also take a look at your lower control arm bushings, and all sway bar bushings.
 

·
Registered
Joined
·
1,640 Posts
It was the center bolt. I had the the little rubber cover over it so it went unnoticed. I took it back and they found the problem and just put another nut on top to hold it down. Now the second nut has stripped and I'm screwed. Hopefully Tokico warranty will replace but I have to take it off and send it in and wait for the new one. That should take all of two weeks. :mad:

I've got my old AAS. Maybe I'll see if they will install that for the time being. XO The car has been in the shop so much that I'm getting a little tired of it. I can't do without my car for that long.

Sorry to get off the subject on your thread bro. Hope you understand.
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #6 ·
the sounds just come from the rear of the car like lose bolts but i havent found any......also sometime i can hear the distrubitor clicking from the rear of the car....but i dont beleive that is much of a problem...maybe just need a new muffler....but i check the exhaust and it wasnt causing the sounds, i have removed the two rear speakers and then went over a couple of pot holes but still heard it some times....it sounds like the shocks maybe out of gas or oil....any light on the subject would be helpful


ratly
 

·
Registered
Joined
·
1,601 Posts
I know that I am going to tighten now my new struts a bit because of a rattle. (just the rears) I was laying down in the trunck yesterday as a friend drove the car around trying to find out where the noise comes from. I did torque them down to what the shop book says, but maybe they have settled some.
 

·
Registered
Joined
·
1,640 Posts
Manifest, yeah it sounds like your new springs may have settled a bit. Did you have any problems setting alignment after installation or are you still waiting to do that?

Ratly, I would try investing in some addco anti-sway bar endlinks. They are cheap and will help with performance as well as probably solve your rattle problems.
 

·
Registered
Joined
·
1,601 Posts
I have yet to get an alignment - got in late yesterday to put on the new tires, and wanted to have everything on before I did it... also giving it some more time to settle. I hope that I can get to that strut nut without having to take of the rear carpet again! Yuck.
 
1 - 11 of 11 Posts
Top