Mazda MX-6 Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
94 Posts
Show me.

Hey Brian, maybe I can take a look at it for you. My guess would be an O2 sensor. You don't have a CEL do you? I know of others who have had O2's go bad and hae not gotten a CEL from it. Maybe I can take a look at it at work within the next couple days, if you work the same days as me. How's has the gas milage been? Well, I'm not a 2.0 expert by any means, but I'll help you out if I can.

Another thing that crossed my mind was the fuel filter may be clogged up(like you mentioned), if you were "(literally) sputtering on fumes to go to the gas station", then maybe the pump was sucking up dirt from the bottom of the tak, in turn clogging the fuel punp. Just a couple things to think about. Let me know what you want to do.
 

· Registered
Joined
·
94 Posts
JspecMX6 how to???

JspecMX-6 said:
Check his fuel pressure regulator too. theres a lower volume of fuel when theres no load on the engine. maybe the fpr puts enough pressure to accomodate that but not a full throttle acceleration (or even less). the sputtering makes me think of inadequate pressure that is relieved ny the sputtering. well good luck!
Good idea, but how do I check the FPR? Like I said, I'm not an expert. :) Someone help please, I'm leaving in about a half hour to go to work and take a look at his car.

Brian, I'm leaving soon, so I'll see you in about an hour. Laters.
 

· Registered
Joined
·
94 Posts
Yeah he has a 2.0, and I don't have a multimeter. We took it for a ride yesterday so he could show me the problem. The car hesitates throughout the entire powerband. IT's not just a low end or top end thing. IT's everywhere. You can also hear this little putting noise from the exaust. So he's gonna replace the fuel filter, plugs, and air filter, and run some fuel injector cleaner in it and see what happens.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top