Mazda MX-6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
I have just gotten the timing fixed on my car every thing is fine its running great but it idles low. i have a mazda mx6 2.0 96 auto. my car had been sitting for like 5 months cause of the timing problem. when i bought the car i changed nothing in it but the water pump altenator and altenator belt. the wires look old could this be the reason. i just had a brand new exhaust system put on so i dont think its that. i have changed no filters so that could be it, or can it? it idles at about 1500 rpm when cold but once warm and u start driviving it changes to about 350. it dont shut off but does do this. can anybody help me out!
 

·
Registered
Joined
·
891 Posts
isnt there a way to adjust your idle? I saw a thread and you can just get a screw driver and the idle control thing is right above the tb.
 

·
Registered
Joined
·
274 Posts
yes you can adjust a screw, but being that that screw hardly ever moves on it's on, chances are you'll just fuck something up instead of fixing it. and if you do it's a temporary fix. Did you replace your:

-Spark Plugs
-Ignition Wires
-Distributor Cap
-Rotor

Did you check for:

-Vaccuum leaks around the IM and TB
-Dirty filter
-Cracked/loose intake piping

My point is basically, there is a lot that can cause a low/rough idle. I have one too. The easiest and quickest fix is almost never worth it in the long run.
 
  • Like
Reactions: Boadicea
1 - 3 of 3 Posts
Top