Mazda MX-6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
921 Posts
Discussion Starter · #1 ·
My car stays at 2k while its being warmed up. It than drops to 1k when driving and when its idling its bouncing from 1k to 2k than to 1k to 2k at a beat. Can somebody help. I look like im reving at people. Is it OK to drive like this cuzz my car seems like its pulling harder? But i think id rather have it fixed tho. Thanks
 

·
Registered
Joined
·
3,167 Posts
Likely a TPS adjustment

iLyK2EaTCiViCs said:
My car stays at 2k while its being warmed up. It than drops to 1k when driving and when its idling its bouncing from 1k to 2k than to 1k to 2k at a beat. Can somebody help. I look like im reving at people. Is it OK to drive like this cuzz my car seems like its pulling harder? But i think id rather have it fixed tho. Thanks
Check the TPS (throttle position sensor) adjustment. Ground the TEN pin in the Diagnostic box and turn on the ignition. If the cooling fan comes on, the idle switch in the TPS is open. Loosen the TPS and rotate it very slowly until the fan goes off. You should have to open the throttle about 0.020" off the throttle stop for the fan to come on. Remove the jumper and start the car to see if it's any better.

You may also have a linkage problem (something holding the throttle plate open slightly). Have you cleaned the throttle body recently? Made any "adjustments" to the air screw on top of the throttle body?
 

·
Registered
Joined
·
921 Posts
Discussion Starter · #3 ·
I have never cleaned or made any adjustments with my throttle body. I was coming home from a long drive. I get off the freeway and everything is fine. Everyting is good until i had to brake hard due to somthing. I have wide pedals and I hit the gas a little on accident and sorta reved my car while braking. I completly stopped and my idle was all out of wack? Why would my car feel a little faster?

Anyways, thanks Mike ill try that right away.
 

·
Registered
Joined
·
921 Posts
Discussion Starter · #4 ·
OK i tried the TPS and that didnt work. I messed with the idle adjustment screw to make my idle normal but its still bounce, barly only like around 200rpms. My friend looked at my plugs and there was oil on JUST the threads on some of the plugs. So im guesing my problem is the valve cover gaskets.
 

·
Registered
Joined
·
921 Posts
Discussion Starter · #5 ·
OK i feel like im talking to myself but oh wells, i just replaced my valve cover gaskets and intalled some spacers and my idle is still a bit ruff, i tried the TPS thing and it did help a bit but its still bouncy. The only thing i can think of is this white piece that is hanging on the bottom of the throttle body. I pulled the trottle body and the 2 cables came out so i put them back not knowing which way. Could that be my prolem and which color goes which? thanks
 

·
Registered
Joined
·
921 Posts
Discussion Starter · #7 ·
It idles perfect when warming up and than acts up as soon as i drive it. Its now bouncing at a different beat than before i changed my gaskets and added the spacers, and not as high of a bounce. My car is also making this loud wistle noise all of a sudden.
 
1 - 7 of 7 Posts
Top