Mazda MX-6 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Has anyone done this? I just got my CAI on Monday and tried to install it on Tuesday, and it will not fit to save my life. It goes in a little ways but it will not go all the way down into the engine bay, or far enough down so I can bolt it down. Any ideas on what I can do?? It looks pretty sweet and I really wanna keep it, but if it won't fit I'll send it back.
 

·
Registered
Joined
·
475 Posts
get a same size piece of pipe and simply add an extention to make it go down further. That is my only suggestion. I believe someone with a probe did something similar with his HS cai for the ATX.
 

·
Registered
Joined
·
1,306 Posts
Make sure you have the correct end going into the VAF and not the other way around. Look in the pic post and you'll see a pic of the intake installed on a PGT (Same car), then match it up and it should fit. There should not be any need to add any extension in order for you to be able to fit the cone filter in. If you still can't fit it, call hotshot and talk to them, they might have sent you the wrong one.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Still not working

Ok... I tried everything both of you suggested, I double checked everything and tried it again and it still wouldn't go in. Its rubbing on the distributor (?) or on the electric fans (not the blades, but the housing), and I've tried everything short of taking it somewhere to get installed. Has anyone ever installed one for an ATX MX-6?? The pictures in the Probe had more room for some reason. But has this been successfully done on an MX-6? If so, is there something I am missing?
 

·
Registered
Joined
·
1,306 Posts
You're going to have to take some pictures of the way you're trying to set it up so we can see. Jusrt as a side note, you're using the silicone coupling that came with the intake correct? You're attaching it to the VAF then you're attatching the filter to the other end of the coupling correct? You need to find out if you have the right one. Take some pics of how it should fit and where it's rubbing. Then we will be able to see.
 

·
Registered
Joined
·
283 Posts
I think I know why it doesnt fit cause there is not ! MADE FOR THE CAR. THe atx is too big to get any intajke down there, i made one for my car and sio far i have herad that i was the only one to do this my filter siots behind my driver sidf fog light i had to cut metal under the battery move th ehorns and alot oshit around and i got a 2 inch piping down teher it was hard but worth it i dunno what hotshot sold u but i be more than happy to help you but get some pics first
 

·
Registered
Joined
·
1,306 Posts
You know what, now that I think about it, I think you are right. I remember a couple years back I was at the tracl with Superwoop. I looked at his engine and he had a lot more room berween the front of the engine and the radiator. I looked at his and I looed at mine and there was maybe a 3" difference in space. That is very odd. Are you able to take pics of your engine compartment and the way you're trying to install the filter?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #9
Gettin' There...

I'm in the process of taking pictures of where its rubbing and what its hittings, but its raining, so I should be finished tomorrow weather permitting. I paid $177.67 from SPMotorsports - http://www.spmotorsports.com It came from Maryland to Georgia in about 3 days.
 
1 - 9 of 9 Posts
Top