Mazda MX-6 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
The lights that are in the door and also on the roof all don't work, the aerial doesn't go up either when i turn the radio on. Also, the car doesn't make that beeping noise when the car door is open, only when the car is turned on does that noise come on.

I have checked the fuses and none of them are blown (thorough check).

Someone please help!
 

·
Banned
Joined
·
2,630 Posts
Did you check the fuses with a test light or taking em out one by one? one of my friends had a similar problem he said he check em all then i check the fuses with a test light bingo.
 

·
Premium Member
Joined
·
1,392 Posts
check ur fuse box and replace the "radio" fuse keeloh knows what he's talking about.
 

·
Registered
Joined
·
235 Posts
Maybe the door switches are bad?
 

·
Premium Member
Joined
·
1,392 Posts
hmm i'm not familiar with the 2nd gen fuse box, do you think it might be the "audio" fuse?
 

·
Premium Member
Joined
·
1,392 Posts
did u find out what the problem was? maybe a harness clip is damaged somewhere. not making contact or something, it's gonna be hard to know unless u take ur time with it.
 

·
Registered
Joined
·
235 Posts
If fuses all check out, and door pins check out then look at the timer control unit. It's responsible for the slow dimming of the lights after you close the doors. It's right above the interior fuse box, by your left foot as you drive. Hard to get to, but sometimes that box gets blown before the fuse does, happened to me.
 
1 - 14 of 14 Posts
Top