Mazda MX-6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
first of all, i'm a new member and i've really enjoyed this site so far. you guys have helped me out a lot already.
right now i'm in the process of installing two 15" neon tubes under my driver and passenger seats. i'm having some trouble with the wiring though. on one side of the toggle switch i have the two positive wires from the two neons and a wire leading to the fuse. the other side of the switch has the two negative wires and the grounding wire. now every time i connect everything and turn the switch on the wire coming from the fuse and the grounding wire burn to a crisp and my car gets filled with smoke. the positive and negative wires ,though, do not burn at all. the fuse i've been using is the fuse that operates the interior lights. i think i'm either grounding the wire on a piece of metal that isn't connected to the frame, or i'm not using a stong enough fuse. any suggestions on what i should do would be appreciated.
 

·
Registered
Joined
·
96 Posts
hey man...I've got two 15" blue neon lights in my car...one even goes with the bass, hehe...but anyway...the wires that come out of the neons should be different..one ground and one power...all I did was hook the power to the battery and back to the switch...the ground was the same thing...to a metal piece somewhere in the engine...and back to the switch
 
G

·
NEONS

MAKE SURE THE METAL YOU ARE GROUNDING TO DOESN'T HAVE PAINT ON IT, IF IT DOES SCRAPE IT OFF WITH A RAZOR, BECAUSE THE PAINT STOPS THE WIRE FROM MAKING A CONNECTION
 
1 - 3 of 3 Posts
Top