Mazda MX-6 Forum banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
My 93 LS (all stock) looses a bit of power after it warms up. It seems to have monster power for the first minute or two of operation, then i probably loose about 15%. I realize that it's natural to loose a little bit, but i never noticed it until a few months ago. I've replaced the plugs, wires which helped with the rough idle. Should i go for O2 sensors and valve cover gaskets now?

And one other question: is there supposed to be a light in the drunk? I can't see a damn thing in that drunk at night.
 

·
Registered
Joined
·
257 Posts
pico1111 said:
My 93 LS (all stock) looses a bit of power after it warms up. It seems to have monster power for the first minute or two of operation, then i probably loose about 15%. I realize that it's natural to loose a little bit, but i never noticed it until a few months ago. I've replaced the plugs, wires which helped with the rough idle. Should i go for O2 sensors and valve cover gaskets now?


- do u have an aftermarket intake? most intakes place the filter right behind the fan & radiator. the fan kicks on once the car is warm, that will make it quite sluggish. look into that.
-ignition related stuff wouldnt really be effected by the temp.
-do u get any CEL codes? if u dont get an O2 code, they're prolly fine. try resetting your ECU anyway. never hurts.
-do u have an automatic? if so, change the tranny fluid?
-and valve cover gaskets will not effect power at all.
-do a VRIS test also. that too never hurts.
-is the power loss at a specific area of the power band?

And one other question: is there supposed to be a light in the drunk? I can't see a damn thing in that drunk at night.
yes, there is. its under the rear deck. covered by a white dome.

L8R
Nick
BLUMX6
 

·
Registered
Joined
·
1,291 Posts
The reason why the car has more power when cold is that it uses a rich fuel mixture to warm up the car and plus the engine is cold.
 
1 - 4 of 4 Posts
Top