Mazda MX-6 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter · #1 ·
I just got the J-spec Cam from Cork Sport... and installed it along with 8 lifters... now my idle is wierd.. any suggestions on how to fix it.... and anyone know where to get lifters for the I4 instead of the factory.. they are 50$ EACH!!!!!..... thanx
 

·
Registered
Joined
·
3,167 Posts
95MX6SHOGUN said:
I just got the J-spec Cam from Cork Sport... and installed it along with 8 lifters... now my idle is wierd.. any suggestions on how to fix it.... and anyone know where to get lifters for the I4 instead of the factory.. they are 50$ EACH!!!!!..... thanx
When you say "weird", what do you mean? Lumpy? Slightly unstable? Really unstable? Stalling? Surging?

Regardless, double check that the cam you installed (intake or exhaust?) is "phased" (timed) properly. Take the timing belt cover off and make sure the marks line up properly. I wouldn't expect the J-spec cam(s) to be so aggressive as to produce a bad idle.
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #3 ·
thanks

Hey man.. thanks for the tip.. I didn't think that it would cause the engine to run a little rougher.. but it only does it at idle.. it like flucuates between 1500 RPM and 900 RPM and then usually drops down to about 700 RPM and just runs rough... it kinda has that guzzle noise to it... but I think I am do for a timing belt.. I have about 107K miles on her now.. and I don't know when it was changed last.. I bought it a few months ago with 98K miles on it.. I just thik I need to change the belt.. thanks for your help...
 

·
Registered
Joined
·
100 Posts
? for 95mx6shogun....

where did you get the cam, and how much? does it make a noticable difference? i am thinking of getting one real soon when i have the engine rebuilt. also if you find a place thats got the lifters cheap let me know, mine are noisy as well.

--mcbride
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #5 ·
CORK SPORT

I got the cam from http://www.corksport.com its about 168$.. I think about 182$ after tax and shipping...... I couldn't really notice a big difference.. but I have raced a few people and I have done better since the cam.. I raced a buddy of mine in a 2000 Cavelier and kicked his ass... before I got the cam he had more pick up then me. and I couldn't beat him.. now I can.. but I have done a few more things to it.. like change the fuel filter.. which really helps.... and I have not found a place that has aftermarket lifters yet.. but I am still looking.. the dealer is way to high.. surely someone out there makes one for it.... but ohh well....
 
G

·
You can order them from machine shops from the internet. I ordered a set for like $280. That is all 16 for the 2.0l. Do the math, that is less than $20 each. Do a search on HLA's. You will get some BS hits. Wade through the shit and call the machine shops. Good luck
 

·
Registered
Joined
·
100 Posts
do you remember the exact site

if you remember the exact site let me know, i would like to order from them, thanks.........

--mcbride
 
G

·
I just checked my credit card receipts and I don't have a website address or phone number, but I do have a Company Name, address, and total including shipping.

Best Bilt Parts
2527 E. Kearney
Springfield, MO 65803

$273.81 for all delivered to my door UPS. Use information to find their number and call them. I got mine last September.
 

·
Registered
Joined
·
108 Posts
for anyone else who has installed this j-spec cam from corksport; i have heard a lot of stories from probetalk and other places that have said that it makes u run a little rougher and makes u die every once in a while and i was wondering if anyone has had any problems with this and can u let me know after u get yours done installing it did the timing fix the roughness from the cam? thanks
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #10 ·
cam install

I got the cam in my car a few weeks ago.. it runs nice and strong now.. but I do feel the roughness and I haven't had a chance to change the timing belt.. it is about time for a new one and I am hopeing that that fixes the roughness.. but I do know that you have to adjust the idle alot... I think I have mine just about right.... it idles at the same RPM now and I haven't had it die on me.. even ith AC and everything on high.. no problems.. just a little rough.. but I am kinda getting use to the sound.. it sounds like a little muscle car at a red light it has that glub glub sound to it.. just not as loud as a V-8..... but It is growing on me.... I just need to get my lifters changed out then I am in business..... ohh yeah.. for anyone who cares.. I just got the SHOGUN body kit put on.. and just got my ENKEI FUBUKI 17x7 RIMS put on.. it looks bad as hell.. I love it.. MX-6 ROCKS.... P E A C E O U T
P.S. thanx for the help on the lifters 3rd_time
 
1 - 10 of 10 Posts
Top