Mazda MX-6 Forum banner

41 - 60 of 138 Posts

·
Registered
Joined
·
831 Posts
Discussion Starter #41 (Edited)
I haven't had the funds to buy the rear mount just yet. One problem about this is that the oil pan touches the sub frame. If the engine is lifted for comfortable clearance the linkage hits the rack. I think I am going to put spacers on the subframes to lower them about an inch. Another thing is that the 2nd gen radiator is to long and if a radiator is mounted in the stock location there wont be room for fans. I am going to have a custom radiator made, one with a cap on the top. If the engine is pushed back for radiator/fan clearance than the linkage will have to be shortened.
 

·
Registered
Joined
·
4,493 Posts
why not run the stock dual core 1st gen radiator, with a puller fan located in front of it? works just fine. and the dual core rad will be plenty for the KL. a puller fan would be alot cheaper then a custom radiator.
Wouldn't it be a pusher fan? I run my fan in front of my radiator in mine, and i've got it pushing the air through the radiator into the bay. :)
 

·
Registered
Joined
·
4,493 Posts
yup. i meant pusher. thats what i get for posting 5 min after i wake up. lol
Mine's reversable. It was pretty cool when i got home and almost overheated the car in the driveway the day i bought it, because it was in pull mode installed on the bumper side of the radiator.

I guess maybe it was supposed to pull the hot air OUT of the engine bay, through the radiator? Awesome.
 

·
Registered
Joined
·
831 Posts
Discussion Starter #46
I would use the 1st gen radiator, but the inlet and outlet is on the opposite side. those would be some silly hoses.
 

·
Premium Member
Joined
·
3,355 Posts
Where are the inlets and outlets on the radiator for the vulcan engined Probe ?

Maybe it would be more suitable.

Otherwise I would take a trip down to the junkyards with a tape measure and see if you can find another car thats got the right size core with better placement of the inlet/outlet.

Otherwise you'll need to go custom.....I dont know if you guys get the same deals from ASI, but through ebay they will make you up a custom alloy radiator for around $400AUD, theyre based somehwere in south east asia.
 

·
Registered
Joined
·
1,969 Posts
I'm confused as to why you have to rewire the windows, headlights ect. Seems like if you use the 2g engine harness it would work right away besides the gauge cluster. :shrug: Then you could get aftermarket gauges or try and splice the 2g gauge cluster in.
 

·
Registered
Joined
·
831 Posts
Discussion Starter #49
The 1st gen switches are different from the 2nd gen switches. I'm using a complete 2nd harness. I'm using 1st gen door harnesses, had to cut the connector going into door of the 2nd gen and splice in the first gen harness. The power mirror switches are in a totally different locations between 1st and 2nd gens. One is located on the master switch and the other on the center console. I have to cut connecters of 1st gen harness and splice them to the 2nd gen harness to get the headlights, tailights, parking lamps to turn on. The harzards and turn signals are the only thing I got to work so far besides the windows/locks. Headlights are giving me trouble though. I probably am going to make a custom cluster because the 1st gen speedo is cable driven.
 

·
Registered
Joined
·
2,299 Posts
When I started putting everything together for my swap, I didn't have a pan...later acquired the pan and hadn't gotten back to the project, and now that you say that, it should have lcicked when I got my pan...the sumps on the wrong side, just like a kia pan on an fe3...how bad do the interfere? less than an inch, or more? might be able to modify my crossmember when it comes time...
 

·
Premium Member
Joined
·
3,355 Posts
or the pan off a KF or K8
 

·
Registered
Joined
·
2,299 Posts
I would assume the k pans to all be the same, but not sure...still new to anything 2gen...that looks like it can be clearanced, though, thanks for the pics...
 

·
Registered
Joined
·
1,969 Posts
The 1st gen switches are different from the 2nd gen switches. I'm using a complete 2nd harness. I'm using 1st gen door harnesses, had to cut the connector going into door of the 2nd gen and splice in the first gen harness. The power mirror switches are in a totally different locations between 1st and 2nd gens. One is located on the master switch and the other on the center console. I have to cut connecters of 1st gen harness and splice them to the 2nd gen harness to get the headlights, tailights, parking lamps to turn on. The harzards and turn signals are the only thing I got to work so far besides the windows/locks. Headlights are giving me trouble though. I probably am going to make a custom cluster because the 1st gen speedo is cable driven.
but why are you using the complete 2g harness? Why not just the engine harness? Just seems like way less work. Maybe i'm missing some thing here...
 

·
Registered
Joined
·
831 Posts
Discussion Starter #56
but why are you using the complete 2g harness? Why not just the engine harness? Just seems like way less work. Maybe i'm missing some thing here...
The engine harness isn't a standalone harness. It connects to the main fuse box harness which connects to the dash harness which plugs into the in-car fuse box and the chassis harness plug into that. It all ties in together somehow. Plus I like having OBDII and Keyless Entry now.:tup:
 

·
Registered
Joined
·
831 Posts
Discussion Starter #57
Since my 89 has a manual rack. I'm am deleting P/S. I know that the water is driven off the same drive and don't want to run the grooved side of the belt on the tensioner. Do you think I could use a fan spacer to bring out the pulley, so it can be run on the alternator drive? I would need to get a belt one rib thinner.
 

·
Registered
Joined
·
2,299 Posts
I bought a car for parts that had the ps deleted...I'll see if I can put it together how he had it...already disassembled the motor and didn't think much of it at the time...
 
41 - 60 of 138 Posts
Top