Mazda MX-6 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
My MX6 has the orginal radio on it that came with it and i whant to change it and put a CD Player in my car and when i took the shuff out to put my cd palyer i got lost in the whires and i didn't whant to mess it up and then not have any kind of muzic and i figured since you guys have more experience with cars and Steros i should ask for your advice. I'm looking for a configuration on the whires. They are mostly blue and with stripes on them or green. I dont know witch goes where and i realy don't whant to fry my car because i'll never get anoter one if i **** it up. So if any one can help me please do.

Hey thx anyway.
If you guys live in State of Washington i would love to meet sometimes and talk about cars.
 

·
Premium Member
Joined
·
7,327 Posts
It sounds like you haven't put stereos in cars before. When you took out the stock radio, you should have unplugged 3 things out of the back of it: the wiring harness, the ground wire, and the antenna. Make sure you don't cut the harness off! Now you need to go to a store that sells car audio accessories (Best Buy is one place) and get 2 things : a Wiring Harness adaptor (which plugs into the harness which was plugged into the back of the radio) and a Mounting Kit. Then you need to solder the wires from the new harness you bought to the wires on the new CD player(this can be done out of the car). Since our cars have a separate ground wire, you'll need to go into the car and solder the ground wire (the separate, black wire attached to the car) onto the black wire coming out of the CD player you bought. Just plug the antenna and harness in and mount according to the instructions in the kit.

If all else fails just have a car audio store install it.

Good luck.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #3
I wish i could say that was eazy but it wasnt because i havent done it, my car has like 2 plastic plugs with 4 wires and then one with 3 wires adn there is an oter on with 2 and a last one with one wire + antena and blak/Gound.:( so that dosent realy work and i don't know what else to do. I wish i could meet with some and actualy have a person who has done it before do it on mine. I dont whant to risk anything do to the fact that i dont whant to have any problems with my car. One of my friends some how hooked his cd player and got some wires wron and now when he steps on the gas every 100 miles his wipers go on once and stop.???
Thx for advive anyway.
 

·
Premium Member
Joined
·
4,971 Posts
What you CAN'T screw up

There are three wires that will screw up your car if done wrong. The RED wire is the power wire that feed the player it's power while the player is on and playing music. The YELLOW wire gives the unit power while the car is off to save station presets, time, etc. The BLACK wire is the ground wire, and feeds the red and yellow wires back to the battery. There will be a BLUE wire for the power anntenna. The other wires are for the speakers. These should be green, purple, grey and white, all with a matching wire with a stripe, 8 total, so you have 2 for each speaker. If you use an amp for the rear, don't use the grey and white wires. If you use an amp for both front and back, ignore all 8 of these wire all together. Wverything SHOULD be color coded.

SUMMARY: DON'T SCREW UP THE RED, YELLOW, or BLACK wires. If you do, it could screw up you car.
 

·
Registered
Joined
·
57 Posts
I would like to add to this conversation if I could. I just bought a 93 mx6 and the previous owner must have changed the factory deck to an after market deck and then removed it when he put it up for auction. Anyhow, my problem is that when I have my aftermarket deck installed it pops the fuse for the tail lights. There we a few different items plugged into the back of my deck that I have never seen before when doing decks. I have been doing my own decks for close to 10yrs. I have one that is similar looking as the antenna plug that I cannot hook to anything as well as one black wire with a square prong that plugged into the factory deck and once I have everything hooked up (power,egnition,ground, speakers) I still have two remaining wires that I dont know what they are for and I am curious to know if these wires should be hooked to something. They are (green with white stripe and brown with grey dots) CAN ANYONE HELP ME PLEASE? I dont want to blow any more fuses.
 

·
Registered
Joined
·
1,193 Posts
Riiiise from the grave, riiiise oh 6 year old post....
Wait, did you say 93??
Dowwwwwn incorrect forum, dooooooownnn!
You need the 2nd gen forum.
 

·
Registered
Joined
·
1,193 Posts
He's prolly dead, or driving a Honda. I can't say which is worse.
 

·
Registered
Joined
·
2,684 Posts
hopefully not driving a honda.... :lol: ....not that im wishing he is dead or anything
 

·
Registered
Joined
·
96 Posts
Discussion Starter #10
Im still alive Driving a 2000 VW Passat 1.8T . After i sold the MX6 i went hardcore VW i was impressed with my golf. And i think im going to stick with VW. I can't seem to find the same power in a Mazda that i can afford. Maybe if i find a GT first gen and got to town, bigger turbo , manual boost controller, (chip) etc what i did to my passat
 

·
Premium Member
Joined
·
899 Posts
These are what you need;)




these connect to the factory plugs<> which the bare wires then gets "soldered"(for best sound) to the harness that came with your aftermarket cd/dvd player head unit.

Ford/Mazda Receiver Wire Harness

For select Ford and Mazda models, 1989-up

Item #120707901
In Stock
$12.99

Ford/Mazda Receiver Wire Harness For select Ford and Mazda models, 1989-up at Crutchfield.com

ohh and this as well:
Mazda In-dash Receiver Kit

Fits select 1986-up models
Chassis sizes S & E, rack-mount


Item #120997501
In Stock
$19.99


you wont use everything on this picture.
i just orered these and finished my install a few days ago with a sweet looking Alpine:)

Hope this helps 1st genners during a 1st time install:lol:, im a visual person as well;)
 

·
Banned
Joined
·
371 Posts
while we're on this topic..i could use a little help. the six i picked up had a af deck in it already....buttt it wasnt done properly..meaning the harness was hacked 8-( everything seems to work fine except apparnt. he never hooked up a 12v constant source. so everytime i shut the car off and restart it erases all the preset face colors,audio,and i have to flip the face and eject the cd before it'll play...FTMFL!!! so could someone tell me which factory wire is the 12v constant? what color combo?
 

·
Premium Member
Joined
·
241 Posts
I just installed a used stereo in my '90 GT. I went to circuit city and got 2 harnesses that pluged my new radio into my factory wiring harness. Hooked up the ground,antenna, and had the thing playing before I knew it! I didn't by the dash kit(dohhh) and spent the rest of the knight trying to fab a bracket. It's to hard and causes cd's to skip on not that rough of roads! The guy I got the unit from thought he would have to solder wires, but it was plug and play!ROCK'N!:cool:
 
1 - 14 of 14 Posts
Top