Mazda MX-6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter · #1 ·
I HAVE HAD A LUMPY IDLE FOR A WHILE NOW AND I HAVE BEEN TRYING TO FIGURE WHAT IT IS. THE ENGINE IDLES A BID HIGH, AROUND 850 OR SO. THE TACH IS ROCK SOLID AT THAT IDLE SPEED , BUT I CAN FEEL THE ENGINE PULSATING. I AM THINKING THAT IT IS POSSIBLE A BAD O2 SENSOR? ANY HELP WOULD BE APPRECIATED.

THANKS
SIXER
 

·
Registered
Joined
·
73 Posts
I have the same problem on my pgt lately, when the rpm doesn't float up and down it's feels very rough and I can feel it pulsating as well. I haven't gotten a chance to take it in yet, but I plan to this week, I'll let you know what happens so you have something to shoot for. Right now I'm thinking it's belts and/or motor mounts.
Matt C.
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #3 ·
YAH, THAT WOULD BE GREAT, JUST LET ME KNOW WHAT HAPPENS. I WANT TO BE MORE ACTIVE ON THIS SITE, BUT I AM A RELATIVE NEWBIE TO THIS SERIES OF CAR AND BESIDES CARBON KNOCK OR BLOCKED HLA'S I REALLY CAN'T OFFER MUCH ADDVICE, BUT I SUPPOSE THAT WILL COME LATER WITH EXPERIENCE.

THANKS FOR YOU HELP!

SIXER
 

·
Registered
Joined
·
1,679 Posts
dont u caps all the time man, just a idea, but for real, the TPS sensor could be, or the throttle body might have something wrong with it, i have heard both of them can mess up the idle, how about the spark plug??
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #5 ·
Sorry about the caps thing, it does look bad, but I have had both of those things checked last time I had my car in the shop. The TB was removed and cleaned when the ICV was replaced this summer, along with wires and plugs, and they mentioned that they would check the TPS. Maybe they didn't check the TPS. I don't know, but I am pretty sure that they are a reputable shop.

sixer
 
1 - 5 of 5 Posts
Top