Mazda MX-6 Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
I have a 90 mx6 lx, the main fuse keeps blowing everytime i plug the battery back up, could this be the starter shorting out or the alternator?


Also when reading over the Faqs a couple days ago i saw one listing some books that were sugguested for helping with mazdas anyone know the link?
 

·
Registered
Joined
·
2,419 Posts
Have you replaced the starter? If so, then i'd suggest looking over the wiring again. It could be that you have some wires reversed. Although I don't recall it being possible since there are different connectors for both poles.

Something is obviously shorting out though. What have you replaced recently?

As for the manual you're refering to....that would be the mazda factory service manual. Brand new can be a little pricey (but worth every penny), or you could find some on ebay and even here on the forum floating around sometimes.

A manual that is not so recommended is the haynes /chiltons manual that can be had at any discount autoparts store. It's mainly based on the older models and is not very detailed.

Give us a little more information on your problem so we can help to solve it. :)
 

·
Premium Member
Joined
·
7,327 Posts
Starter hot wire is not fused so it's not the starter. I would try unhooking the large bolted-on wire from the alternator and see if the fuse still blows then. Make sure to disconnect ground wire from battery end before you disconnect this to avoid massive sparks. (Reconnect the - terminal of battery after you've disconnected the big wire from alt)
 

·
Banned
Joined
·
4,087 Posts
It could also be that you have the leads on the battery hooked up backwards. That will make it blow in an instant:eek:
 

·
Registered
Joined
·
1,193 Posts
It could also be that you have the leads on the battery hooked up backwards. That will make it blow in an instant:eek:
I was installing my new Odyssey gel cell and stupidly hooked it up backwards and car is dead. So is the main fuse the 80 am fuse that is bolted in with 2 10mm bolts? Is there any reason to believe I may have damaged anything else in the car like my ECU?
 

·
Banned
Joined
·
4,087 Posts
My buddies car fucntions fine and we blew the main fuse 6x in a row trying to figure out the problem.:lol:



I dont see why it would effect the ECU:confused:. I would figure that the main fuse would blow long before the short would reach the ECU.:shrug:


So is the main fuse the 80 am fuse that is bolted in with 2 10mm bolts?
Yes. (OR a 100A on some Probe models:eek:)
 

·
Registered
Joined
·
275 Posts

·
Registered
Joined
·
1,193 Posts
I dont see why it would effect the ECU:confused:. I would figure that the main fuse would blow long before the short would reach the ECU.:shrug:
Because fuses, especially old and BIG ones aren't "fast" enough.
BUT.. thats good to know that you blew 6 in a row with no after effects. I DID hear a "click" under the dashboard... Im just hoping that was a relay letting go and not a CAP in the ECU popping. Good news is I didn't "smell" anything...

So we will see..
I assume this 80A fuse WITH THE LEGS and HOLES in it, I can just get at OHelly or AutoBlown?
 

·
Banned
Joined
·
4,087 Posts
I assume this 80A fuse WITH THE LEGS and HOLES in it, I can just get at OHelly or AutoBlown?
SHould be able to. I found them at just regular auto parts stores here. (Though they were $3-5 apeice or so:()
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #10 ·
Hello guys been away for a while, life problems.... anyway i got the problem with fuse corrected, thats all good now. Now i just got to get it started, might just need gas seeing as how its been sitting since april of 07 :p. Now that i have the time i'm gonna continue where i left off.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #11 ·
Fuse fixed, car wont start

Now i cant get the car to start, Its turning over but it wont start. I was thinking maybe i'm not getting any gas to the engine? any thoughts or idea wehere to start, until i can get that manual to help would be helpful?
 

·
Registered
Joined
·
2,684 Posts
did you check all the fuses under the dash to make sure they were alright also? Since the car has been sitting for almost a year maybe you should go get a gallon or two of gas and put it in the car.


When you say the car is turning over, are you getting spark, fuel pump turning on etc?....little more detail
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #13 ·
Well i didn't check fuses under the dash, will do that in a bit after this post.

How can i tell if the fuel pump is turning on?

I also did put in 3 dollars worth before trying to start it.
 

·
Registered
Joined
·
2,684 Posts
if you listen closely you can usually hear the fuel pump turn on if turn the ignition on without starting the car since the fuel pump is located right under your backseat.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #15 · (Edited)
Well I guess thats were I'm going to have to start. I heard nothing when i turned the key, and i repeapted several times just to be sure. So any links/step by steps to help and a price range would be helpful. I am going to try to do a bit of searching myself also.

Thanks for the help so far it has been very helpful

Yea I also checked all the fuse in under the dash, and they checked out ok

I took this with my camera phone its attached right to the bottoom of the fuse box didn't know if anything was supposed to be attached to it or what??
 

·
Registered
Joined
·
2,684 Posts
right below the fuse box? Let me run out and check really quick...





Alright i just checked and i had a yellow w blue stripe wire running to it but it did not connect to anything. I'm not quite sure what it is there for but it does not need to be connected...
 

·
Registered
Joined
·
1,193 Posts
Are you following the wiring diagrams posted online in a couple of places?
Also FYI, you cant view those pics without a myspace acct. Use photobucket or other.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #18 · (Edited)
yea I did that on short notice was in a rush, But her it is on photbucket



I still think it might be the fuel pump from what i have read from earlier help with this
 

·
Registered
Joined
·
2,684 Posts
what color wire and how many are coming from it? If thats the same one i looked at under my fuse box then it does not connect to anything.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #20 ·
I was talking to a friends of mines dad, and he saw it sitting here and i told him hat when i turn the key it just acts like it wants to start u, but nothing happens, and he stated that the head might be bad in it. So what should my next step be in fixing his, or should i take it to a shop and just let them figure it out. not trying to spend a whole getting this engine fixed if i could just do a swap and solve he problem.

Wasn't interested in doing a swap @ the moment tho. just wanted it back on the road. any comments would be helpful
 
1 - 20 of 25 Posts
Top