Mazda MX-6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
416 Posts
Discussion Starter #1
hey, im just wondering a few things about my 93 LS (V6, 5 speed).....it has 69,000 miles and i just did the 60k service and the previous owner had just done the timing chain. i am curious as to what might be needing a replacement soon, i have heard the watewr pumps are faulty, but i don't know when they start to go, also, how often shuld i change my plugs and wires on this car??? does it show any noticeable signs when they need replacing?? thanx for the help
 

·
Registered
Joined
·
483 Posts
here is a pretty good list...

-fuel filter
-spark plugs
-wires
-inspect hoses and belts check to see if they are tight
-drain and fill antifreeze that is a must because that can lead to faulty water pumps
-air filter or clean it depending on which filter you have

if you did the 60,000 mile maintanence then you should have had the plugs and wires replaced.

Anthony
 

·
Registered
Joined
·
74 Posts
Start saving for the clutch....it'll be going soon. Get a Centerforce or ACT.
 

·
Registered
Joined
·
294 Posts
Here's some other little things you can/should replace:


PCV valve
Fuel Filter
Other belts (serpentine)
Clean fuel injectors
Distributor Cap


LaTeR...

:eek:
 

·
Registered
Joined
·
2,064 Posts
Clutches do not necessarily go at 60000 miles. Mine has 127500 on it. No slipping.

You can probably hold off on the water pump until the second timing belt job (120000 miles), but if it doesn't fail before then, definitely do it then.

Keep a watchful eye on the spark plug wells....the valve cover gaskets leak oil into the plug wells.

You will notice a misfire or rough idle when the plug wires start to wear out; it's probably not necessary to replace them until then. That said, mine went at 55000 miles.

Tyson
 

·
Registered
Joined
·
371 Posts
Where did you have the 60K tune up done at? I would make sure that your plug wires are not the origionals. I would keep an eye out for oil in the spark wells (every oil change I check) I am still using the factory clutch and I just turned 129K. If they did a decent tune up I am sure they replaced the pcv, but check on the fuel filter. Oh, almost forgot... your O2's will be going out in about 10K.
 
1 - 6 of 6 Posts
Top