Mazda MX-6 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,855 Posts
Discussion Starter · #1 ·
I just bought my 1989 MX6 GT. I had a 1990 GT, that I wrecked. Well, sometimes, the 89 really wants to "run", or haul freakin' ass. Other times, it is almost just like a "peppy" 4 cylinder. I'm entertaining pulling the front off of the 89 and putting it on my 90, cause that darn 90 always ran. EVEN my GIRLfriend notices the difference.

Has anyone else had any problems with their GTs?
Somtimes, it wants to go, other times it does NOT, what is the deal?

Let me know.
 

·
Registered
Joined
·
287 Posts
I used to have that prob when I didn't let it warm up even in the summer.
 

·
Registered
Joined
·
318 Posts
My car, even though an LX, has days like that. 1 trip it will be running like a champ, the next its just another car.
 
G

·
I also experience different performance at different times. I have not been able to pin-point why, and my mechanic says it's in my head! There is definetely a significant difference, but I have not found it to be heat related. I am also running a stock standard system.
 

·
Registered
Joined
·
235 Posts
I feel your pain I cleaned my throtle bodies and that help a bit to gain back performance, but I still have those days
 

·
Registered
Joined
·
666 Posts
Let me tell you about problems Jiffy!
No, on second thought, why go on and on and on?
Yes, I've had the same experience. Our cars are just quirky! BTW, I'm in the Midland/Odessa Texas area. I wouldn't mind scamming some parts from your car!
What color is it? Interior?
Looking for blue, but, grey would be good, too.
 

·
Registered
Joined
·
1,855 Posts
Discussion Starter · #7 ·
Hey TexasMX6GT, guess what? I was born in Odessa, and like all my family (from my Dad's side) lives there. How old are you? Know any Gifford(s)?
 
1 - 7 of 7 Posts
Top