Mazda MX-6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
Car keeps throwing a mass airflow code (and sometimes, though rarely, a air temp code as well). I replaced the mass air flow sensor thinking that this would resolve the issue, and nope! I hate to have to take it to someone (I'm fairly broke lol) it was suggested that there may be a vacuum leak somewhere, like a cracked intake tube, but if there is, I can't find it. Everything I can see is all in great shape. I keep reading about "vacuum boxes" under the intake manifold, but I don't really know what to look for, and my Haynes manual is useless in this regard. Any thoughts or pictures of these? I'm going :jump: trying to avoid going to the shop. It idles fine, but if you turn on the A/C, the idle is erratic. There is also random stalling, and it's running richer than George Lucas. I'm lucky to be getting 20 MPG, and you can smell that the thing is pissing gas, and black smoke betimes. Heeeeeelp! lol :shrug:
 

·
Registered
Joined
·
1,171 Posts
it sounds like maybe a bad maf sensor.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #5 ·
is ECM any differant than the ECU? cause i cant find it for cheaper than $80 at the places i CAN find it... where online could i go to find it?
 

·
Registered
Joined
·
2,879 Posts
Go to grand prairie off of loop 12 and jefferson / davis (these roads run parallel to each other) there are a bunch of junk yards there with lots of 2g mx6 you should be able to find it pretty cheap there.
 
1 - 8 of 8 Posts
Top