Mazda MX-6 Forum banner

1 - 5 of 5 Posts
G

·
Discussion Starter #1
Hey guys! I am having a terrible problem with the moonroof on my '93 MX-6. I have to give it a shove to help open it, and I also have to help it close. It seems like it has lost all of it's power! Has anybody else experienced the same problem? Please help!!
 

·
Registered
Joined
·
194 Posts
You know how it goes up in two stages? First it opens, then you have to release and press again to move it back. In the first step, going up, it sometimes has that problem, and I have to push it up. Seems to happen when it's colder out. That means below 70 down here. Haven't really bothered to ask anybody about it.
 

·
Registered
Joined
·
459 Posts
It could be that the motor in the roof is getting old and the brushes are getting worn and it's losing power so it can't pull itself out. If you can check it out with a multi meter to see how it's behaving.

You said moonroof, as in glass roof?? Did you get that put in aftermarket? I'd like to see if I could get my roof converted to a glass top.
 
G

·
Discussion Starter #4
No. It's called a moonroof I believe, but it is not glass (it is the original). I would also like to see about putting in a glass one as well. I am having a heck of a time with rusting on the roof . . . glass would give that problem. A lot of water is trapped there due to the rubber seal and it just rusts away. . .
 

·
Registered
Joined
·
806 Posts
I've heard to lubricate the slides on both sides helps some. White lithium grease should do the job nicely especially if you have some corrosion going on. Sounds like its not draining properly.
 
1 - 5 of 5 Posts
Top