Mazda MX-6 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
1,089 Posts
Discussion Starter · #1 ·
Ive been toying with this profec for a couple days now...I went off sixsick6 settings for a base on the high boost..The thing I cant figure out though is he has his start booost set at 116...I thought that was out of a possible 300...so if 100kpa=14.5lbs...and Im trying to boost 11 or 12lbs wouldnt 116 be like setting the start boost to 16.5lbs???? Im guessing a number like 91 would be much closer to my target?? or is my logic all fudged up?

Ive got the boost set to 11lbs...gain at 40...and start boost at 116...it will spike to 12 or 13 then drop down to 10 and hold that...Is my spike being caused by the start boost or is the gain still to high?

Also lemme just shout out all the people who tried to help me out...and to all the haters who said Id never get it running perfectly eat-a-dick:flipa: ... No more issues my friends...The car is fast as hell on 11lbs pretty soon Ill get some pictures of my setup on here.
 

·
Banned
Joined
·
27,927 Posts
Start boost is used to adjust boost response and is when you want the wastegate to start opening. If you want that at 300 then be my guest, I don't. It was kept low because when the start boost is close to the set boost, the turbo spools faster. If it is too close, then you will have boost spike, like you have. When you get spike, lower the gain. If your boost tapers off before halfway to redline or still rises as rpm rises, you can raise the gain even though you haven't changed the SET. Raising gain will raise your boost regardless of SET.

Read your instructions again and come up with your own set of values. Your car is not my car and my car is not your car. You are in a blizzard right now and I can still wear shorts at 6 am and pick up my morning paper without any shoes and the most I'll get is beach sand between my toes.

This is going to drastically change how things operate/respond.
 

·
Registered
Joined
·
1,089 Posts
Discussion Starter · #3 ·
LOL Yes I am in a blizzard luckily I got the car home before it...Ive had it fixed since tuesday finally got to the oil pump and alignment...and I didnt need camber plates... was trying to get the boost to hold without spike...It actually only took me only 2 days and 5 small adjustments...once I figured the only gears I could really study gauges in is 4th or 5th..

Ive memorized the instruction manual I was just wonderin if there were any real shortcuts to getting it there faster...

As it stands Im holding 11psi with no spike...I get full boost at 2500rpms..so much karma to you sick as your settings are not far off from mine...so you can add them to the the rest...It may help someone...next is 15psi...after the blizzard that is :)

Boost 11psi..steady no spike
Set 18%
Gain 40%
Start Boost(Set Gain) 114
 

·
Registered
Joined
·
1,089 Posts
Discussion Starter · #5 ·
No I have the actual manual...thanks
 

·
Registered
Joined
·
19 Posts
Brass Restrictor & Gain

Ok I found my Brass Restrictor!
Should I be using it with my Profec B spec II ??

If so, which line ?

Also you guys set GAIN of 40%, my max gain is 35%??
Wat THE?:confused:

Thanks guys,
Dave
 

·
Registered
Joined
·
19 Posts
Max Gain 35%

Well I searched the forums for ages trying to look for the answer about the maximum 35% gain.

Few people have asked, but NO1 has answered it! Strange...:(

Anywayz I used SixSick6's settings of:
11-12psi
Set: 30%
Gain: 50%
Startboost: 116

But I flipped the SET and GAIN setting, SO:

MY Setting
Set: 50%
Gain: 30%
Startboost: 116

Seems to WORK SWEET! Peaked at about 13.5psi.
Didn't try it for long, but so far haven't had ANY! boost fall off
WOOOOOOOOOOHOOOOOOOOOOOOOO :jump:


Still don't know if I should be using that Brass Restrictor.. :(
And still not sure what the 'LIMITER' does...

I had the warning set at 13psi and when it peaked ova it beep and cut the boost off. Maybe thats all I need ?
Now set at 14 of course :D

Thanks for the help so far guys,
Would prob be dead already without this website.

Dave
 

·
Banned
Joined
·
27,927 Posts
The Brass restrictor is an IHI thing. It's found in the Subaru turbos as well as the MX6. I called Greddy myself and asked for their advice on whether or not to use it.

The answer I got was along the lines of-

"The solenoid that we use is pretty consistant so you shouldn't have to use that restrictor. This isn't the first time we have goteen this question from Mazda or Subaru owners. Although I'm saying you shouldn't have to use it, I'm certainly not saying you can't or shouldn't use it. Try it with and without and see what you think, and let us know when you do."

Let's add this in so it's in the same spot:
http://www.mx6.com/forums/1g-mx6-forced-induction/178524-definitive-profec-specb-thread.html
 

·
Registered
Joined
·
19 Posts
I see....

Alrighty.

I spose I will try it with and without then.
Thanks SixSick6.
Oh
and it doesn't matter which side of the profec solenoid you put it in does it?

Also was I right in flipping your SET and GAIN around?
Is that how you have yours setup?

And did you try with and without?
What did you find worked best ?

Thanks again,

Dave
 

·
Registered
Joined
·
1,089 Posts
Discussion Starter · #10 · (Edited)
I think your starting to get a good understanding my only problem with sick settings are his set boost and gain settings are flipped...so yes you are correct notice everything I said in this thread is from over a year ago...the newer thread was done from alot of test boosting and actually logically working out the settings rahter than just going lemme try sicck's which I did when I first tried to set it...

to get down to 11-12 psi lower both the set boost and gain setting slightly...I have never used the brass restrictor..

The warning feature is set like the startboost between 0.00 and 3.00 I have mine set to 1.50...

The limiter is the percentage that it will knock down boost once it hits the warning....I have mine set at 20% this can save your motor...

One day when it was around -20 wind chill here...Im matting it with my normal settings and it just kept going I spiked nearly 20lbs! heard the warning and the limiter kicked in and took me back down to 13.5...prolly saved my motor cause Im the type of ass that just has to see when the needle will stop..I could have let off...if your like me or in a actal race situation this feature is extremely useful..
 

·
Registered
Joined
·
19 Posts
Awesome

Thanks soo much mate,
Your a CHAMP!

I have done soo much searching through the forums and couldn't find the simple answers.
Alright I am all good and ready to go.

Thanks boys.
Will let u kno how I go eventually :cool:

Dave
 

·
Registered
Joined
·
19 Posts
All Good!!!

Alright no more playing around.

SixSick6's setting flipped around:
Set: 50%
Gain: 30%
Startboost: 116

WORK PERFECT!!!!

Round 2psi at 2000rpm
Then it just hits ROCK SOLID 12.5psi !!!
Could not find any FALL OFF!!

Soo happy. I won't bother trying 16 again.
Even when it was good in 2nd gear it was too easy to spin..

Thanks boys.
WOOOOOHOOOOOOOOOOOOOO:angel:
DAve
 

·
Registered
Joined
·
1,089 Posts
Discussion Starter · #13 ·
now try solid motor mounts and trans mounts and some heavy springs up front and you can turn that spin into go juice...I dont break em loose course I dont even boost in 2nd at 16-17psi its preety useless:)
 
1 - 13 of 13 Posts
Top