Mazda MX-6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I have a 9e MX6 w/ 2.5 l v6 and it starts and runs but you don't l.ow for how long. I need to know how to tell if its a bad fuel pump or a problem with my ignition system. Will appreciate your help.I got what was told to get, an ignitor, but it isnt what some repair books show as a engine control module that am being told that is the problem.Please help. Thank You.
 

·
Registered
Joined
·
2,692 Posts
When the engine dies, does the rpm shown on the tachometer suddenly drop to 0, even when the car is still rolling and engine still turning? If so, that sounds like a bad ignitor in the distributor (the normal fix is to replace the distributor). And you can also check that hypothesis by checking for spark. And if it restarts after it's cooled down, that also suggests bad ignitor/distributor.

If the engine dies more slowly, sputtering to a halt, that sounds more like a bad fuel pump.

From reading this board over decades, bad ignitor/distributor is much more common than bad fuel pump.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
When the engine dies, does the rpm shown on the tachometer suddenly drop to 0, even when the car is still rolling and engine still turning? If so, that sounds like a bad ignitor in the distributor (the normal fix is to replace the distributor). And you can also check that hypothesis by checking for spark. And if it restarts after it's cooled down, that also suggests bad ignitor/distributor.

If the engine dies more slowly, sputtering to a halt, that sounds more like a bad fuel pump.

From reading this board over decades, bad ignitor/distributor is much more common than bad fuel pump.
Thanks that is what I will replace
 
1 - 3 of 3 Posts
Top