Mazda MX-6 Forum banner

101 - 120 of 124 Posts

·
Registered
Joined
·
7,692 Posts

·
Registered
Joined
·
221 Posts
Discussion Starter #102
ahh, i forgot that o-ring... thnx!

i havent had any cooling water problems, i think. its bubling a little in the expension tank when i squice the radiator hose, but that just normal?
 

·
Registered
Joined
·
1,633 Posts
Ya the oil hole is probably an issue with the MLS gasket as it was with the copper ones. I used an injector o-ring and it worked great perfect fit.
 

·
Registered
Joined
·
678 Posts
The squice-thing on the radiator hose = bubbles in exp. tank is normal, atleast with the radiator cap off, I havent tried it without.
 

·
Premium Member
Joined
·
2,003 Posts
Nice pics! Sorry to hear about the leaking though :( Did you install the gasket dry, or used some sort of sealing agent, like Hylomar?
 

·
Registered
Joined
·
221 Posts
Discussion Starter #107
i instaled it dry the first time, but when i fixed the leaj, i applied a thin thin layer of "the right stuff" gasket over the whole tingh, with o-rings where the oil controll plug its, on both sides.

today i will try to fix another problem, one of the injectors sucks false air. so it only goes on 3, but when i giggle it a little it runs fine, so i need to look at the orings and gaskets on the injectors...

here is a pic of how the engine looks:
 

·
Registered
Joined
·
221 Posts
Discussion Starter #108
finaly no oil leaks, and a steady oil pressure :D
 

·
Premium Member
Joined
·
3,355 Posts
Yeah, nice....

Now all you have to do is loose the heavy cast iron exhaust manifold....not that it flows badly or anything, it weighs nearly 20kg!
 

·
Registered
Joined
·
221 Posts
Discussion Starter #112
hehe i know! its heavy as hell! i think i have to make myself a new manifold, but thats not a priority right now... I am still happy just becouse the engine runs normal :D
 

·
Registered
Joined
·
221 Posts
Discussion Starter #114
yea i know! :D

are you coming to gatebil at vålerbanen later in may? then you can test it :D
 

·
Registered
Joined
·
17 Posts
Have you done any test Dyno runs yet? I am looking into doing something similar in my MX3. I want to stay 4cyl and I need more displacement.
 

·
Registered
Joined
·
221 Posts
Discussion Starter #117
nope sorry, havent used it in i while, got a free to use car at work, and i am still suffering low oil pressure:( planing to fix it in my vacation
 

·
Registered
Joined
·
17 Posts
^stalking me are ya :p
you know it! I can't let you have all the fun! I may go with a FS from a 93 MX-6 for now, mainly because I am having a hard time finding a sportage in the junkyards with gas prices what they are.

Any updates? This Build is killing me, I can't wait to see how it performs when the bugs are worked out! :tup:
 

·
Registered
Joined
·
333 Posts
This would be a very nice manifold for you:



Is a 4 into 1, they join beneath the olipan.
 
101 - 120 of 124 Posts
Top